Closed Bug 959557 Opened 6 years ago Closed 6 years ago

WEBM vp9 video can not be decoded on some devices

Categories

(Core :: Audio/Video, defect)

27 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 833023
Tracking Status
firefox26 --- affected
firefox27 --- affected
firefox28 --- unaffected
firefox29 --- unaffected

People

(Reporter: cos_flaviu, Unassigned)

References

()

Details

Environment: 
Device: Google Nexus 7 (Android 4.4.2);
Build: 27 beta 6 (2014-01-14).

Steps to reproduce:
1. Load http://base-n.de/webm/out9.webm;

Expected result:
Video loads and starts playing.

Actual result:
The following message is displayed: "Video can't be played because the file is corrupt."
I/MediaPluginHost( 2001): Android Version is: 19
I/MediaPluginHost( 2001): Android Release Version is: 4.4.2
I/MediaPluginHost( 2001): Android Device is: Nexus 7
I/MediaPluginHost( 2001): Android Manufacturer is: asus
I/MediaPluginHost( 2001): Android Hardware is: flo
I/MediaPluginHost( 2001): Loading OMX Plugin: libomxplugin.so
I/MediaPluginHost( 2001): OMX plugin successfully loaded


E/GeckoConsole( 2001): [JavaScript Warning: "Media resource http://base-n.de/webm/out9.webm could not be decoded." {file: "http://base-n.de/webm/out9.webm" line: 0}]
Component: General → Video/Audio
Flags: needinfo?(edwin)
Product: Firefox for Android → Core
Summary: webm video can not be played → WEBM video can not be decoded on the Nexus 7 (2013)
Version: Firefox 27 → 27 Branch
The bug is also reproducible on the following devices:
- Asus Transformer Tab (Android 4.0.3);
- Samsung Galaxy Tab (Android 4.0.4);
- Google Nexus 4 (Android 4.4.2).
Summary: WEBM video can not be decoded on the Nexus 7 (2013) → WEBM video can not be decoded on some devices
Video is VP9. Marking a dupe of the support VP9 codec.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(edwin)
Resolution: --- → DUPLICATE
Summary: WEBM video can not be decoded on some devices → WEBM vp9 video can not be decoded on some devices
Duplicate of bug: 833023
You need to log in before you can comment on or make changes to this bug.