Closed Bug 959715 Opened 7 years ago Closed 7 years ago

[B2G][Camera] Pinch to zoom in camera app switches orientation of screen

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S1 (14feb)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: bzumwalt, Assigned: justindarc)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screenshot
Description:
When user zooms by pinching on camera or video screen of Camera app the orientation of the screen is changed. If user is holding phone in portrait mode, zooming causes video capture portion of screen to switch to landscape orientation (and visa versa.) 

Repro Steps:
1) Updated Buri to Build ID: 20140114040616
2) Open camera app
3) Pinch to zoom in on screen

Actual:
Camera screen switches orientation when pinch to zoom is performed.

Expected:
User can pinch to zoom on camera screen without screen switching orientation.

Environmental Variables
Device: Buri v 1.4 Mozilla RIL
Build ID: 20140114040616
Gecko: http://hg.mozilla.org/mozilla-central/rev/34dddf6f7ec1
Gaia: 002cca258af8586859c6efb2dada2fcec36754a1
Platform Version: 29.0a1
Firmware Version: V1.2-device.cfg


Notes:
Repro frequency: 3/3, 100%
See attached: screenshot and video clip - http://youtu.be/Ma-rnD1sMNo
Does this reproduce on 1.3 or 1.2?
Keywords: qawanted
This does not reproduce on today's nightly Buri v1.3 or on Buri v1.2

Environmental Variables
Device: Buri v1.3 Mozilla
Build ID: 20140121004137
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/6f7dfe36ab6c
Gaia: 47049555282a9a01fb60d1e1421b57e2810c96f5
Platform Version: 28.0a2
Firmware Version: v1.2-device

Environmental Variables
Device: Buri v1.2 Mozilla RIL
Build ID: 20140114004002
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/42a1c35fc831
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Platform Version: 26.0
Firmware Version: v1.2-device
QA Contact: pbylenga
blocking-b2g: --- → 1.4?
The regression window is 1/9 to 1/10.

Last nightly build issue does not reproduce on:

Environmental Variables
Device: Buri v1.4 Mozilla RIL
Build ID: 20140109040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/9409405e0739
Gaia: 47206ac66b084c6f6c4503a3b10d0e0760df2b6f
Platform Version: 29.0a1
Firmware Version: v1.2-device

First nightly build issue reproduces on:

Environmental Variables
Device: Buri v1.4 Mozilla RIL
Build ID: 20140110040206
Gecko: http://hg.mozilla.org/mozilla-central/rev/37516445a0b5
Gaia: f400efc804366c7b7cf5476d1d5d325e6651ee71
Platform Version: 29.0a1
Firmware Version: v1.2-device
Assignee: nobody → jdarcangelo
Depends on: 933902
The pinch-to-zoom gesture is being refactored to utilize the camera hardware API which should, in turn, automatically resolve this issue. Added reference to Bug 933902.
Since 933902 fixes this issue, changing target mile stone to 1.4 S1
blocking-b2g: 1.4? → ---
Target Milestone: --- → 1.4 S1 (14feb)
(In reply to Sri Kasetti from comment #5)
> Since 933902 fixes this issue, changing target mile stone to 1.4 S1

That's not acceptable to make this a non-blocker. This is a regression with bad impact, so this should block the release. We should not assume a refactoring will land in a release to automatically resolve this - this should blocked & tracked independently to fix what regressed here.
blocking-b2g: --- → 1.4?
I meant to make this a 1.4 blocker
blocking-b2g: 1.4? → 1.4+
jsmith: Good call. I'll submit a patch to fix this regression today.
This is an interim fix for this bug until patch for 933902 lands
Attachment #8375718 - Flags: review?(wilsonpage)
Attachment #8375718 - Flags: review?(wilsonpage) → review+
Target Milestone: 1.4 S1 (14feb) → 1.4 S2 (28feb)
Target Milestone: 1.4 S2 (28feb) → 1.4 S1 (14feb)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.