Closed Bug 959781 Opened 6 years ago Closed 6 years ago

[FTE] Scrolling though Your Privacy E.me page causes very bad text overlapping (with APZ enabled)

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
blocking-b2g 1.4+
Tracking Status
firefox28 --- wontfix
firefox29 --- fixed
b2g-v1.4 --- fixed

People

(Reporter: nkot, Assigned: nrc)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image screenshot
Description:
When the user scrolls very fast in Privacy Policy E.me page it causes very bad text overlapping - see screenshot. It doesn't reproduce with APZ disabled in Settings.

Repro Steps:
1) Updated Buri to BuildID: 20140114040616
2) Launch FTE 
3) Hit Next until About Firefox OS page
4) Select Your Privacy link
5) Select Everything.me
6) Scroll up and down very fast

Actual:
The text will overlap

Expected:
No overlapped text

Environmental Variables:
Device: Buri v1.4 (master) Mozilla RIL
BuildID: 20140114040616
Gaia: 002cca258af8586859c6efb2dada2fcec36754a1
Gecko: 34dddf6f7ec1
Version: 29.0a1
Firmware Version: v1.2-device

Notes:

Repro frequency: 100%
See attached screenshot
Component: Gaia::First Time Experience → Graphics
Product: Firefox OS → Core
This is definitely a regression.

What happens on 1.2 & 1.3?
blocking-b2g: --- → 1.4?
Keywords: qawanted, regression
QA Contact: sparsons
Unable to repro on Buri 1.3 Build ID: 20140114004002

Gaia   96c05def12ed7a9896b23f45398e361a97d2ce0e
SourceStamp 29c5b8def408
BuildID 20140114004002
Version 28.0a2

Also, Unable to repro on Buri 1.2 BuildID: 20140114004002

Gaia   539a25e1887b902b8b25038c547048e691bd97f6
SourceStamp 42a1c35fc831
BuildID 20140114004002
Version 26.0
Keywords: qawanted
Regression Window:

Last Working Environmental Variables:
Device: Buri v1.4 Mozilla RIL
BuildID: 20140113040202
Gaia: fd3b9a97cb3c41cfa56be387b46a51db136b4422
Gecko: 12d3ba62a599
Version: 29.0a1
Base Image: V1.2-device.cfg

First Broken Environmental Variables:
Device: Buri v1.4 Mozilla RIL
BuildID: 20140114040616
Gaia: 002cca258af8586859c6efb2dada2fcec36754a1
Gecko: 34dddf6f7ec1
Version: 29.0a1
Base Image: V1.2-device.cfg
Hi Vivien,

is this still repro after the work you did in FTE?
Flags: needinfo?(21)
(In reply to Francisco Jordano [:arcturus] from comment #4)
> Hi Vivien,
> 
> is this still repro after the work you did in FTE?

I can not reproduce the issue. I wonder if this issue is not related to the hardware compositor ? Since with APZC scrolling will use the compositor.  Natalya can you check if you have hardware compositor enabled in Settings -> Informations -> More Informations -> Developer ?
Flags: needinfo?(21)
I reproduced the problem on master hamachi by disabling hw composer.
From Comment 3, I checked a bug that causes the regression. Bug 935377 seems to causing the regression.
Nrc, can you comment about Comment 7?
Flags: needinfo?(ncameron)
(In reply to Sotaro Ikeda [:sotaro] from comment #9)
> Nrc, can you comment about Comment 7?

Is that the right bug number? Seems unlikely a URL change would affect graphics performance.
Flags: needinfo?(ncameron)
(In reply to Nick Cameron [:nrc] from comment #10)
> (In reply to Sotaro Ikeda [:sotaro] from comment #9)
> > Nrc, can you comment about Comment 7?
> 
> Is that the right bug number? Seems unlikely a URL change would affect
> graphics performance.

Sorry, Bug 951554 is correct bug number.
Flags: needinfo?(ncameron)
Ah, yeah it is highly likely that those changes regressed this. I'll try to investigate. In the meantime I am happy to back out 951554.

Cwiiis: could you give a brief description of how APZC interacts with buffer rotation? I guess I missed something in 951554 for the APZC case.
Component: Graphics → Graphics: Layers
Flags: needinfo?(ncameron) → needinfo?(chrislord.net)
(In reply to Nick Cameron [:nrc] from comment #12)
> Ah, yeah it is highly likely that those changes regressed this. I'll try to
> investigate. In the meantime I am happy to back out 951554.
> 
> Cwiiis: could you give a brief description of how APZC interacts with buffer
> rotation? I guess I missed something in 951554 for the APZC case.

Sorry, I'm really not sure what you mean :/ APZC doesn't really change anything about how drawing happens as far as I'm aware, only that with a displayport set, visible regions are likely to get bigger. BenWa might be able to better answer your question, transferring needinfo to him in case.
Flags: needinfo?(chrislord.net) → needinfo?(bgirard)
Cwiiis is right. There's no magic. Just the buffer will be larger and resize more often without tiling.
Flags: needinfo?(bgirard)
Assignee: nobody → ncameron
Flagging as 1.3? as the text overlapping also occurs in the AccuWeather app (bug 964517) and that was flagged  1.3+.
blocking-b2g: 1.4? → 1.3?
(In reply to Botond Ballo [:botond] from comment #16)
> Flagging as 1.3? as the text overlapping also occurs in the AccuWeather app
> (bug 964517) and that was flagged  1.3+.

This bug is thought as regression of Bug 951554. It is committed only 1.4(master). If bug 964517 happens also on v1.3, it seems another problem.
I confirmed on jan/22 v1.3 hamachi. I did not saw text overlapping. But sometimes I saw black background drawing during scrolling.
Black background drawing seem different problem.
(In reply to Sotaro Ikeda [:sotaro] from comment #19)
> Created attachment 8367483 [details]
> screen shot of the black drawing
> 
> Black background drawing seem different problem.

Yeah. I filed bug 965389 for that.
> 
> Yeah. I filed bug 965389 for that.

I am not sure that bug 965389 is same to Comment 19. In comment 19's case, the problem happens when a email address 'unsubscribe@everyghing.me' is hidden upward. It seems that some code misjudges the text is as selected.
(In reply to Sotaro Ikeda [:sotaro] from comment #17)
> (In reply to Botond Ballo [:botond] from comment #16)
> > Flagging as 1.3? as the text overlapping also occurs in the AccuWeather app
> > (bug 964517) and that was flagged  1.3+.
> 
> This bug is thought as regression of Bug 951554. It is committed only
> 1.4(master). If bug 964517 happens also on v1.3, it seems another problem.

You're right, after further investigation bug 964517 looks like it's unrelated. Changing back to 1.4?
blocking-b2g: 1.3? → 1.4?
This restores the behaviour which I stomped all over with my SyncFront... optimisations.
Attachment #8367776 - Flags: review?(matt.woodrow)
Attachment #8367776 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/c98dcb17b56b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
blocking-b2g: 1.4? → 1.4+
You need to log in before you can comment on or make changes to this bug.