communicate roadmap for FxA and sync when we turn on the feature by default in Fx29 nightly



Cloud Services
Server: Firefox Accounts
4 years ago
3 years ago


(Reporter: edwong, Assigned: rlord)


Firefox Tracking Flags

(Not tracked)


(Whiteboard: [qa+])



4 years ago
1. Need to communicate roadmap for self hosted servers. (no UI, but can use about:config pref)
2. Need to communicate roadmap for level of crypto between sync 1.1 and sync1.5 with FxA.
3. Introduce the idea of FxA
4. Possibly address COPPA/CHIPA/CIPA support?


4 years ago
Assignee: nobody → rlord
Whiteboard: [qa+]

Comment 1

4 years ago
FxA + Sync FAQ for Nightly channel launch Etherpad:

Current best thinking:

- PMs will author copy
- UX will define UX link/embed

Comment 2

4 years ago
Chatting this over with the team here and we feel like an FAQ is probably not necessary for a Nightly uplift, but a blog post authored by the Sync/Services team feels like the right approach to us.
I concur - blog post + some social media outreach to Nightly users & Developers is likely sufficient. (ie @FirefoxNightly and whatnot)

Comment 4

4 years ago
PR should be informed of our plans so they can review.

Comment 5

4 years ago
Drafting via Etherpad:

Who in PR? 
Which blog? Presumably the most Firefox Nightly-ish one.

Comment 6

4 years ago
I added Eric and Laura to the bug and I've been filling in PR as well as we've been proceeding.  Now adding Shannon as she should be first point of contact.  Eric/Laura/Shannon, perhaps you can discuss in SC this week?

Comment 7

4 years ago
Welcome Eric, Laura and Shannon. 

So, we need to resolve/close this ASAP, Fri Jan 24 at the latest as it is blocking the FxA + Sync Nightly release.

So, current best thinking: 

* Post to the Identity Services blog (
* Socialize via @FirefoxNightly Twitter Account, get other Mozilla Twitter accounts to retweet it.

Chad, please confirm that non-goal is any link from within the desktop nightly, prefs or otherwise. 

Given all of the above, I'll work with Chris Karlof to ensure completeness/correctness of post then update this bug when we're happy w/ text for (quick) approval w/ Eric/Laura/Shannon. Good plan?

Thanks everyone,

Comment 8

4 years ago
If I understand the ask correctly, I can confirm that your two-pronged plan: 1)posting to the IS blog and using the @FxNightly seems like a good plan.  Nothing beyond that is required on Desktop side.  Clear?

Comment 9

4 years ago
Per the stand-up mtg on Tues, Jan 24: 

* Chris Karlof + Mark Mayo will author + publish post to addressing topics/concerns to security and migration attuned audience. 


* is an externally hosted Tumblr blog, which limits our ability to seamlessly server-side redirect in the future. Flagged as a future facepalm. 
* I'm seeking out the Tumblr blog sign-in credentials.

Comment 10

4 years ago
JGruen in IRC pointed out may be a better location for post.

Comment 11

4 years ago
Hi all - Erica will follow up here. she has been having offline conversations with Lloyd/Mark Mayo and has a communication plan for this. Thanks!

Comment 12

4 years ago
Everyone, we're on a very short fuse here. This bug *MUST* be closed with our current best thinking by end of day today to prevent blocking the Nightly release at the Thursday, Jan 23rd, 10AM PST stand-up meeting tomorrow. 

At bare minimum, we need the *URL* for these two "Using Sync on an older Firefox?" links in Nightly:

Because the content is server-side it can be updated and the URL can be redirected. However, without an URL, we may block. 

My current best thinking for the URL: which we can redir later to the apropos URL. I fly that in sync-tactics this am and see what happens.

Comment 13

4 years ago
301 FTW.

Toby Elliot confirmed in IRC that is available as our redir URL. I checked this approach w/ CKarlof. He agrees that a redir URL is sufficient to unblock Jan 24th Nightly launch. 

While we are unblocked, we still need comms for legacy sync users. I'll continue nudging this bug to close w/ Mayo, Lloyd, Eric, Erica and others.

Comment 14

4 years ago
ok just following up w/the comms plan details and recapping convo w/Rob. we will *not* tweet from @firefoxnightly. That is not an official account and we are not trying to proactively push this to the public until at least Aurora.

For this to move forward in nightly the following comms details need to be in place: 
- copy/messages that can be used for blog post (to be posted on the Future of Firefox blog) and for support articles (for existing sync users and new accounts users)
- internal/press reactive FAQ (Shannon and Paul will circulate for answers)

The PR team can move in a matter of hours to finalize things (while not ideal for global translation) but we will do everything possible to support this being communicated in nightly on friday 1/24.

We will then work w/Mark on a vision blog post about Accounts to go on the main Moz blog, twitter and global press outreach when this moves forward to Aurora.

Comment 15

4 years ago
Thanks Erica. 

To clarify and assign remaining actions to close this bug: 

* Mark Mayo + Chris Karlof are tasked with drafting a post for legacy sync users addressing top anticipated concerns and providing guidance tailored to the Brendan cohort/Wizard segment. Current best thinking is the post will live on the Mozilla Services blog: Erica Jostedt + PR/Comms team will review post.

Comment 16

4 years ago
Hi Rob - Just a few points of clarification: 
- It would be great if Mark/Chris could create an article for our support forums by EOD today 
- Erica and I will then take those details and do a quick post for the Future Release blog, where we announce new features in Firefox and ask for testers
- We'll also circulate questions for a reactive, internal FAQ. We'll need the team to help us fill out the answers. 

If we can get the content/language ASAP but by EOD today that would be great.

Comment 17

4 years ago
As of Jan 23, discussion of all FxA + Sync PR/Comms has moved to an Etherpad:

Given we have an URL redir plan as well, I plan to close this bug.


4 years ago
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 18

4 years ago
Reopening by request of Ibai/SUMO so there's a Bug for tracking. 

From is the release plan for the SUMO articles. 

What's communicated in the articles will be supported by the internal FAQ:

3a. Rob/Ibai Initial Sumo Article to support #1
Target: SUMO (1/31)
Goal: Address likely questions resulting from the desktop and Android nightly "Using Sync on an older Firefox?" links. (derived from #2)
 3b. Ibai/SUMO Team
Target: SUMO, between Aurora and launch
Goal: Update canonical Sync support articles with Fx29 FxA/Sync info + screenshots:
Resolution: FIXED → ---

Comment 19

4 years ago
Here are links that you can use to point to the sumo documentation:
For Firefox use this:
For Firefox for Android use this:

Ricky, can you point these urls to this support article?
Flags: needinfo?(rrosario)

Comment 20

4 years ago
Sorry for the confusion. The link for Firefox for Android should be:
The redirect has been created in prod.
Flags: needinfo?(rrosario)

Comment 22

4 years ago
Thanks Michael + Ricky. 

Curious why we want/need VERSION, OS and LOCALE given the page is guaranteed (?) to open in Firefox w/ all that available, no?

Comment 23

4 years ago
(In reply to rlord from comment #22)
> Thanks Michael + Ricky. 
> Curious why we want/need VERSION, OS and LOCALE given the page is guaranteed
> (?) to open in Firefox w/ all that available, no?

This is so we can send users to different support articles if necessary (may not be in this case).

Comment 24

4 years ago
(In reply to Verdi [:verdi] from comment #23)
> (In reply to rlord from comment #22)
> > Thanks Michael + Ricky. 
> > 
> > Curious why we want/need VERSION, OS and LOCALE given the page is guaranteed
> > (?) to open in Firefox w/ all that available, no?
> This is so we can send users to different support articles if necessary (may
> not be in this case).

r1cky provided this documentation: 

AFAIK, we're good w/ the URLs provided. I'll bring up at our Tuesday stand-up to check. 

Thank you SUMO team!
FYI, Bug 957426 will ensure that when this link is clicked in the Sync options page, Desktop Fx will open (with appropriate version, os and locale links, via Services.urlFormatter.formatURLPref(''))

Comment 26

4 years ago
Update: the link txt has now changed to "Using an older version of Sync?" because you can have old Sync running on new Firefox somewhere else.

Comment 27

4 years ago
I have :ckarlof approved-sufficient-to-unblock-turning-on-Nightly copy here: 

:verdi, pls migrate to SUMO ASAP. I'll ping you in IRC as well. In addition to this text, perhaps we auguent w/ a walk-thru, screenshot, etc. Let's discuss. 

Next stop: EJ and Paul in PR/Comms.

The finish line is in sight.

Comment 28

4 years ago
Hi All,
Per Rob's last note above is there any outstanding work that still needs to happen here or can we call this done?

Calling this done
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.