[Buri][DSDS] After enter incorrect PIN code 3 times, PUK page is not shown in a row.

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: echu, Unassigned)

Tracking

({regression})

unspecified
x86_64
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Whiteboard: dsdsrun1.3-2)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8360247 [details]
time stamp: 16:01, 1/15

Both single SIM and dual SIM devices have the bug. And Buri v1.2 has no such problem.
Gaia      539a25e1887b902b8b25038c547048e691bd97f6
Gecko     http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/42a1c35fc831
BuildID   20140114004002
Version   26.0

When enter incorrect PIN code 3 times, PUK code page is not shown. User have to suspend/resume or using other way to trigger the page.


* Build Number  
Fugu              
Gaia      a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
Gecko     15ee4e78431b45922b41dea882464b0ccb6b4fac
BuildID   20140110174141
Version   28.0a2

* Reproduce Steps
test on Fugu.
1. Enable both SIM cards PIN code.
2. Reboot device.
3. After enter OS, unlock screen, SIM 1 PIN entry page shows.
4. Enter incorrect PIN 3 times, you will see SIM 2 PIN entry page without seeing SIM 1 PUK page.
5. Enter incorrect SIM 2 PIN code 3 times. System just go to home page.

* Expected Result
PUK page should be displayed after 3 PIN trials failed.

* Occurrence rate
100%
(Reporter)

Comment 1

5 years ago
Created attachment 8360249 [details]
VID_0001.3gp
(Reporter)

Updated

5 years ago
See Also: → bug 926351
Status: NEW → RESOLVED
blocking-b2g: 1.3? → 1.3+
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 959971
(Reporter)

Comment 3

5 years ago
(In reply to Preeti Raghunath(:Preeti) from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 959971 ***

Hi Preeti,

The steps and symptoms are different between these 2 bugs, are they really the same one? What's the reason of it?
Flags: needinfo?(praghunath)
(Reporter)

Comment 4

5 years ago
Verified.

Fugu - 
Gaia      bb36b4164d3e51ca04b612e507e1178f80bf240d
Gecko     4227240a4d3e1e418ced160c2a48cb454d7b5645
BuildID   20140204104742
Version   28.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(praghunath)
Resolution: DUPLICATE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.