[DSDS] When one SIM is active, still user can access Call Settings of another SIM card.

VERIFIED FIXED in Firefox OS v1.3

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: echu, Assigned: jaoo)

Tracking

unspecified
1.3 C3/1.4 S3(31jan)
x86_64
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 verified)

Details

(Whiteboard: dsdsrun1.3-2, [FT:RIL])

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 8360292 [details]
time stamp: 17:40, 1/15

When one SIM is active, still user can access Call Settings of another SIM card. This failed user story bug 926350 and UX spec.

* Build Number  
Fugu              
Gaia      a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
Gecko     15ee4e78431b45922b41dea882464b0ccb6b4fac
BuildID   20140110174141
Version   28.0a2

* Reproduce Steps
1. MO call from SIM 1.
2. During the call, go to settings > Call setting, select SIM 2.

* Expected Result
SIM 2 should be grey out.

* Actual Result
Still can access SIM 2 call setting.

* Occurrence rate
100%
(Assignee)

Comment 1

5 years ago
I tested that yesterday and It was working for me. I'll take a look again.
(Assignee)

Updated

5 years ago
Assignee: nobody → josea.olivera
(Reporter)

Comment 2

5 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #1)
> I tested that yesterday and It was working for me. I'll take a look again.

Because I will not update build daily for this regression test, feel free to ni? me if this is fixed in latest build, I will come back and verify it again once I complete all the test cases.
blocking-b2g: 1.3? → 1.3+
(Assignee)

Comment 3

5 years ago
Took a look at this bug and it works correctly.

Gaia: eec6ab24d922531a8d53f22e0d974c8620f7c051
Gecko: c0dd1c1e3fed7e4cb6bca0695736b2e687806291
Version=29.0a1
BuildID=20140117154806
Flags: needinfo?(echu)
Keywords: qawanted

Comment 4

5 years ago
Adding QARegressExclude as QAnalysts does not have a duo SIM device.
Whiteboard: dsdsrun1.3-2 → dsdsrun1.3-2, QARegressExclude
Whiteboard: dsdsrun1.3-2, QARegressExclude → dsdsrun1.3-2, QARegressExclude [FT:RIL]
(Reporter)

Comment 5

5 years ago
Hi José,

I am testing v1.3 build, the problem can be reproduced, can you check again?

Fugu
Gaia      726ae682da9022bdccc057f29e836eff6a738677
Gecko     6ea72307375cfa123d2ec81f29ccc86976134b2a
BuildID   20140120153149
Version   28.0a2

Thanks.
Flags: needinfo?(echu)
Keywords: qawanted
Whiteboard: dsdsrun1.3-2, QARegressExclude [FT:RIL] → dsdsrun1.3-2, [FT:RIL]
(Assignee)

Comment 6

5 years ago
Just built the same build and I cannot reproduce the issue. Here are the build information (taken out from objdir-gecko/dist/b2g/application.ini) and gecko and gaia commit hashes:

Vendor=Mozilla
Name=B2G
Version=28.0a2
BuildID=20140120102522
SourceRepository=6ea72307375cfa123d2ec81f29ccc86976134b2a
ID={3c2e2abc-06d4-11e1-ac3b-374f68613e61}

Gecko commit hash:
commit 6ea72307375cfa123d2ec81f29ccc86976134b2a
Author: Ryan VanderMeulen <ryanvm@gmail.com>
Date:   Sun Jan 19 23:04:26 2014 -0500

Gaia commit hash:
commit 726ae682da9022bdccc057f29e836eff6a738677
Merge: 50d6487 3d63ea7
Author: AndreiH <andrei.hutusoru@gmail.com>
Date:   Sun Jan 19 22:57:59 2014 -0800

Jason, how should we handle this situation?
Flags: needinfo?(jsmith)
Jose - What device are you using to reproduce the bug?

One thing that might help in figuring out this bug is to get a video of the issue on the latest build. 

Enpei - Can you get a video?
Flags: needinfo?(jsmith) → needinfo?(echu)
(Reporter)

Comment 8

5 years ago
Hi all,

I will re-flash my device with same build again, because it seems other people's device with same build also did not have this bug, I will keep you all update!
(Assignee)

Comment 9

5 years ago
(In reply to Jason Smith [:jsmith] from comment #7)

Thanks for the tip.

> Jose - What device are you using to reproduce the bug?

Fugu

> One thing that might help in figuring out this bug is to get a video of the
> issue on the latest build. 

https://www.youtube.com/watch?v=knkMYEc8-c0
(Reporter)

Comment 10

5 years ago
Hi José,

I know what happened. 

Please insert 2 SIM cards in your devices. And please check my video attached later. From your video, you only insert 1 SIM and no voice call is established during the test.

1. Set SIM 1 as primary outgoing call in SIM manager.
2. Make a call to another device, answer the call on another phone.
3. During the call, go to Settings > Call settings.
You will find that you can still access SIM 2 call setting.

Thanks.
Flags: needinfo?(echu)
(Reporter)

Comment 11

5 years ago
Created attachment 8362517 [details]
Enpei's video
(In reply to Enpei from comment #10)

Thanks for your tests.

> Please insert 2 SIM cards in your devices. And please check my video
> attached later. From your video, you only insert 1 SIM and no voice call is
> established during the test.
> 
> 1. Set SIM 1 as primary outgoing call in SIM manager.
> 2. Make a call to another device, answer the call on another phone.
> 3. During the call, go to Settings > Call settings.
> You will find that you can still access SIM 2 call setting.

I see now, we were testing different things. This is not a bug but something not implemented. I was not aware of this requirement. So does it mean only the call settings from the ICC card being set as the primary one should be enabled? Does it make sense? Why is that in such way?
Flags: needinfo?(cawang)
(Reporter)

Comment 13

5 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #12)
> (In reply to Enpei from comment #10)
> 
> Thanks for your tests.
> 
> > Please insert 2 SIM cards in your devices. And please check my video
> > attached later. From your video, you only insert 1 SIM and no voice call is
> > established during the test.
> > 
> > 1. Set SIM 1 as primary outgoing call in SIM manager.
> > 2. Make a call to another device, answer the call on another phone.
> > 3. During the call, go to Settings > Call settings.
> > You will find that you can still access SIM 2 call setting.
> 
> I see now, we were testing different things. This is not a bug but something
> not implemented. I was not aware of this requirement. So does it mean only
> the call settings from the ICC card being set as the primary one should be
> enabled? Does it make sense? Why is that in such way?

As far as I know is that many items in Call setting such as Caller ID, FDN, Call forwarding are required to access network to get the status/values of the SIM card. While SIM 1 is active/in call, SIM 2 cannot access network if you want to open its call setting. You can try the steps again and you should see that system cannot get call waiting, caller ID and call forwarding latest value of SIM 2 while SIM 1 is voice call active.

Hope this can clarify your questions, but if you still need UX input, please then ni? Carrie again.
Flags: needinfo?(cawang)
(In reply to Enpei from comment #13)

> As far as I know is that many items in Call setting such as Caller ID, FDN,
> Call forwarding are required to access network to get the status/values of
> the SIM card. While SIM 1 is active/in call, SIM 2 cannot access network if
> you want to open its call setting.

Yes, that's right. Every RIL request should return generic failure. I got it now. Patch coming. BTW I guess 'active' means here in a call, right? I'll try to figure out how to check whether the ICC card being the primary for outgoing calls is on call or not. Thanks and sorry for the noise.
(Reporter)

Comment 15

5 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #14)
> Yes, that's right. Every RIL request should return generic failure. I got it
> now. Patch coming. BTW I guess 'active' means here in a call, right?
Yes, means in a call.

Please do not hesitate to share your questions. Thank you.
(Reporter)

Updated

5 years ago
Blocks: 926350
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
Created attachment 8364290 [details] [diff] [review]
v2

Arthur, this patch implements the feature requested in this bug. Could you take a look please? Thanks.

PS. The PR is updated as well as you might prefer to review the patch in github.
Attachment #8362853 - Attachment is obsolete: true
Attachment #8364290 - Flags: review?(arthur.chen)
Comment on attachment 8364290 [details] [diff] [review]
v2

Thanks for the patch, Jose. Please check my github comments. And it seems we don't handle the same thing on single sim devices in this patch, right?
Attachment #8364290 - Flags: review?(arthur.chen)
Created attachment 8364983 [details] [diff] [review]
v3

Thanks for the review!

Comments on github addressed. PR updated as well.

(In reply to Arthur Chen [:arthurcc] from comment #19)
> Comment on attachment 8364290 [details] [diff] [review]
> v2
> 
> Thanks for the patch, Jose. Please check my github comments. And it seems we
> don't handle the same thing on single sim devices in this patch, right?

Yes, you're right. This is only valid for multi ICC card devices.
Attachment #8364290 - Attachment is obsolete: true
Attachment #8364983 - Flags: review?(arthur.chen)
Comment on attachment 8364983 [details] [diff] [review]
v3

Much more clear! Thanks for the patch. r=me with the github comment addressed.
Attachment #8364983 - Flags: review?(arthur.chen) → review+
Thanks Arthur!

Landed on Gaia master branch at https://github.com/mozilla-b2g/gaia/commit/3cec0bce6716cb9ef6b80e9eedaca4936948a18b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g-v1.3: --- → affected
Resolution: --- → FIXED
Uplifted 3cec0bce6716cb9ef6b80e9eedaca4936948a18b to:
v1.3: 41b03fade53932b53e9b9ef5206fa283165bbc9a
status-b2g-v1.3: affected → fixed
(Reporter)

Comment 24

5 years ago
Verified on Fugu.
Fugu
Gaia      77fdf058ccb77f40497fb696912a1ce12192eea7
Gecko     9c7f92ffaa19db4a004103104d2da78b8cbd2056
BuildID   20140129130749
Version   28.0a2
Status: RESOLVED → VERIFIED
status-b2g-v1.3: fixed → verified
You need to log in before you can comment on or make changes to this bug.