Phonegap android app L20N 1.0 RC error translating

RESOLVED DUPLICATE of bug 942594

Status

RESOLVED DUPLICATE of bug 942594
5 years ago
4 years ago

People

(Reporter: linke_z, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.68 Safari/537.36 OPR/19.0.1326.26 (Edition Next)

Steps to reproduce:

Updated my version of L20N on my project to 1.0 RC, tested on the browser and everything worked fine. I then put it into a Phonegap project and I got the following error: Cannot read property 'childNodes' of undefined on line 352 of the l20n.js


Actual results:

The application failed to run due to the exception, the screen was blank.


Expected results:

The application should have loaded up the initial screen with all language resources translated into the system browser's default language.
(Reporter)

Updated

5 years ago
Component: General → JS Library
(Reporter)

Comment 1

5 years ago
This error happens because in the overlayElement call overlayElement(node, translation.content) the content property of translation will evaluate to undefined because it is only supported in Android 4.4 and above. If I change it to overlayElement(node, translation) it works as intended. However I should note that in L20N 1.0 RC the data-required-msg attribute is not being respected, the messages I put on those attributes are not shown when validation fails for an input. The message displayed just says that #inputid is required.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942594
You need to log in before you can comment on or make changes to this bug.