Closed Bug 960245 Opened 6 years ago Closed 6 years ago

Deal with the final possibility for degeneracies in FindInflectionApproximationRange

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
Tracking Status
firefox28 --- fixed
firefox29 --- fixed

People

(Reporter: jwatt, Assigned: bas.schouten)

Details

Attachments

(1 file, 1 obsolete file)

Add a finiteness assertion to FindInflectionApproximationRange and clean up some comparisons
This is follow-up to bug 941585 comment 22.
Attachment #8360620 - Flags: review?(bas) → review+
We fail the assertion on content/svg/content/src/crashtests/579356-1.svg , or loading:

data:image/svg+xml,<svg xmlns="http://www.w3.org/2000/svg"><path d="M 0 0 C 0,0 0,0 501.208526,390.4 C 501.208543,390.4 0,0 0,0" stroke="black" stroke-width="5" fill="none"/></svg>
Assignee: jwatt → bas
Attachment #8360620 - Attachment is obsolete: true
Attachment #8361102 - Flags: review?(jmuizelaar)
Comment on attachment 8361102 [details] [diff] [review]
Deal with the final possibly degeneracy in FindInflectionApproximationRange.

Review of attachment 8361102 [details] [diff] [review]:
-----------------------------------------------------------------

Add a test case.
Attachment #8361102 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/fff51472ec53
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Summary: Add a finiteness assertion to FindInflectionApproximationRange and clean up some comparisons → Deal with the final possibility for degeneracies in FindInflectionApproximationRange
Comment on attachment 8361102 [details] [diff] [review]
Deal with the final possibly degeneracy in FindInflectionApproximationRange.

This is a follow-up to bug 941585 which just got aurora approval and landed. Can we get approval for this too, please?

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 930577
User impact if declined: SVG textPath and motionPath breakage
Testing completed (on m-c, etc.): now on m-c
Risk to taking this patch (and alternatives if risky): low risk
String or IDL/UUID changes made by this patch: none
Attachment #8361102 - Flags: approval-mozilla-aurora?
As I noted in comment 3, this has test coverage.
Flags: in-testsuite+
Attachment #8361102 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.