Closed Bug 960351 Opened 7 years ago Closed 7 years ago

browser_bug726427_csstransform_tooltip.js | Test timed out

Categories

(DevTools :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(firefox27 unaffected, firefox28 unaffected, firefox29 fixed, firefox-esr24 unaffected)

RESOLVED FIXED
Firefox 29
Tracking Status
firefox27 --- unaffected
firefox28 --- unaffected
firefox29 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: smaug, Assigned: smaug)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached patch wipSplinter Review
https://tbpl.mozilla.org/php/getParsedLog.php?id=33046746&full=1&branch=mozilla-inbound#error0

This seems to happen randomly with bug 930793, which changes how often we run gecko
events comparing to native os level events in the main loop.

I can't reproduce the issue locally. Guess fix based on 
http://mxr.mozilla.org/mozilla-central/source/toolkit/content/tests/widgets/popup_shared.js#213

https://tbpl.mozilla.org/?tree=Try&rev=d6635ca9ac05
Comment on attachment 8360777 [details] [diff] [review]
wip

Review of attachment 8360777 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/styleinspector/test/browser_bug726427_csstransform_tooltip.js
@@ +151,5 @@
> +  // Run _showOnHover at stable state after the next refresh driver tick.
> +  element.ownerDocument.defaultView.requestAnimationFrame(
> +    function() {
> +      setTimeout(function() { tooltip._showOnHover(element); }, 0);
> +    });

This looks weird at first, but after a discussion on IRC, it seems popup event handling is sometimes a problem that can be fixed with this kind of things.
Some events are dispatched asynchronously, some synchronously, some based on paint event, ...

Since the try build seems to confirm that it fixes this issue, let's go with this fix, but I'd like to ask for a couple of changes:

- A bit more comments to inform what's the exact reason for this fix.
- Use of executeSoon and arrow functions:

element.ownerDocument.defaultView.requestAnimationFrame(() => {
  executeSoon(() => tooltip._showOnHover(element));
});
Attachment #8360777 - Flags: review+
https://tbpl.mozilla.org/?tree=Try&rev=7183177b40dc
should give still some more debug information.
https://hg.mozilla.org/mozilla-central/rev/92f64142decc
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Bug 961004 is a new intermittent that just appeared after this fix it seems.
We might want to revisit this.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.