event.timeStamp is in µSeconds by receiving an WebSocket onmessage-Event

RESOLVED DUPLICATE of bug 238041

Status

()

RESOLVED DUPLICATE of bug 238041
5 years ago
5 years ago

People

(Reporter: m.schmid, Unassigned)

Tracking

26 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140120])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I receive onmessage events and want to use the event.timeStamp


Actual results:

The event.timeStamp-Value is in microseconds (three additional zeros at the end every time)
For example: 1389863531321000


Expected results:

The event.timeStamp-Value should by in milliseconds like in IE and Chrome (tested)
For example: 1389863531321

Updated

5 years ago
Component: Untriaged → DOM: Events
Product: Firefox → Core
Whiteboard: [bugday-20140120]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 238041
You need to log in before you can comment on or make changes to this bug.