pdf.js fails to render photograph in pdf

VERIFIED FIXED in Firefox 45

Status

()

Firefox
PDF Viewer
P3
normal
VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: Tilman, Unassigned)

Tracking

26 Branch
Firefox 45
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/6723, URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8360959 [details]
screenshot-bugzilla.png

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Enter this URL in the browser
https://issues.apache.org/jira/secure/attachment/12546323/missing_image.pdf
or search PDFBOX-1416 on google and display the sample PDF


Actual results:

The "big" photograph of the girl on the right of page 1 is missing, although it appears for a fraction of a second.


Expected results:

The "big" photograph of the girl on the right of page 1 should have appeared
(Reporter)

Updated

4 years ago
Component: Untriaged → PDF Viewer
(Reporter)

Updated

4 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Reproduced on latest Nightly (20140112004002).
Status: UNCONFIRMED → NEW
Ever confirmed: true
With the dev version of pdf.js I can see the image, but it is much more faint than acrobat.
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask]

Comment 3

3 years ago
With the latest nightly it looks like the alpha mask covers the image upside down :). There is almost invisible head of the girl, while in Adobe Reader top of the image is visible and the bottom is not.
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask] → [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/6723
Depends on: 1232015
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
QA Whiteboard: [good first verify]

Comment 4

2 years ago
I have reproduced this bug with Firefox Nightly 29.0a1 (Build ID: 20140116030250) on 
windows 8.1, 64-bit with the instructions from comment 0.

Verified as fixed with latest Firefox beta 45.0b3 (Build ID: 20160204142810)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
QA Whiteboard: [good first verify] → [good first verify][bugday-20160203]

Comment 5

2 years ago
[testday-20160219]  Fix verified using Firefox 45.0b6 . 
The "big" photograph of the girl on the right of page 1 does appear.
Marking as verified based on above comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.