Improve the way we publish the B2G results from the CI server

RESOLVED DUPLICATE of bug 979498

Status

RESOLVED DUPLICATE of bug 979498
5 years ago
a year ago

People

(Reporter: davehunt, Unassigned)

Tracking

Details

Currently the entire contents of src/dashboard are pushed to the target via SSH. This is not cleaned up between builds so we get an accumulation of results. As a result, this means the results are volatile - if for any reason the workspace in Jenkins is wiped out, any existing results on the remote server will be lost. We definitely need a more robust solution for this.

Ultimately we want to submit results to DataZilla (bug 909796) and it might be that we hold out for that, but we also might be able to come up with a better solution in the short term.

If we could just publish the latest test results to a directory on a dashboard server, and have the dashboard process these directories automatically, that might work.
This is best fixed as part of bug 979498. Marking this as a duplicate.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 979498

Updated

a year ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.