Closed Bug 960604 Opened 6 years ago Closed 6 years ago

Deleting a bookmark from "Windows 8 Touch" folder also deletes it from desktop Firefox bookmarks list

Categories

(Firefox for Metro Graveyard :: General, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: mbrubeck, Unassigned)

References

Details

(Keywords: dataloss)

Steps to reproduce:
1) Bookmark a page in Metro Firefox.
2) Switch to desktop Firefox.
3) Add a bookmark to the same page in one of the desktop bookmark folders.
4) Still in desktop Firefox, delete the bookmark from the "Firefox Touch" bookmarks smart folder.

Expected results: The bookmark is gone from the "Firefox Touch" folder and the Metro start page, but is still in the desktop Firefox bookmark folder.

Actual results: The bookmark is deleted from both the Metro bookmarks *and* the desktop bookmark folder.

As pointed out in this forum thread:
http://forums.mozillazine.org/viewtopic.php?p=13300961#p13300961

This happens because the "Firefox Touch" folder in desktop Firefox is actually a "smart" query, so removing an bookmark from it removes all matching bookmarks.

I think we could fix this by displaying the Metro Bookmarks root as a regular folder instead of a query, like we do for the "Mobile Bookmarks" root.
Hi Matt, could you please clarify step 3? I've tried this with both the "Mobile Bookmarks" and the "Windows 8 Touch" folders and it seems for both you cannot 're-bookmark' the same page that already exists in one of these folders. You can move the bookmark, or make a copy of it. And deleting a copy doesn't seem to affect the other. Thanks!
Flags: needinfo?(mbrubeck)
(In reply to Marina Samuel [:emtwo] from comment #1)
> Hi Matt, could you please clarify step 3? I've tried this with both the
> "Mobile Bookmarks" and the "Windows 8 Touch" folders and it seems for both
> you cannot 're-bookmark' the same page that already exists in one of these
> folders. You can move the bookmark, or make a copy of it.

You can add a second bookmark to the same site by dragging a tab from the desktop Firefox tab strip to the bookmark toolbar or sidebar.

> And deleting a copy doesn't seem to affect the other. Thanks!

Ah, I just realized that my steps to reproduce were wrong.  Deleting a bookmark from the "Windows 8 Touch" smart folder won't delete matching bookmarks from desktop folders -- but it will cause the deleted bookmark to disappear from any other smart folders or queries where it appears, like the "Recently bookmarked" and "Unsorted bookmarks" lists.

There's not much we can do about that, so I think we might need to WONTFIX this bug.  Users who don't want to see the Windows 8 Touch smart folder in desktop Firefox can just delete it.
Flags: needinfo?(mbrubeck)
Summary: Deleting a bookmark from "Firefox Touch" folder also deletes non-Metro bookmarks → Deleting a bookmark from "Windows 8 Touch" folder also deletes it from desktop Firefox bookmarks list
hmm, I still don't see the issue with the "Recently bookmarked" or "Unsorted bookmarks" losing the bookmark. Maybe there is a repro step still missing. But I do agree we can resolve as wontfix or invalid since this is expected behaviour.
Resolved invalid since it's expected that deleting a bookmark will also delete it from "Recently bookmarked" and "Unsorted bookmarks" queries, if it's the only copy of the bookmark.
No longer blocks: metrov1backlog
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Whiteboard: [triage] [defect] p=0
You need to log in before you can comment on or make changes to this bug.