[B2G][FTE] Outlook icon is showing up briefly when tapping on email field in the Facebook log in screen

RESOLVED FIXED in Firefox OS v1.4

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: nkot, Assigned: alive)

Tracking

({regression})

unspecified
1.4 S2 (28feb)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.4+, firefox28 unaffected, b2g-v1.4 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
When importing Facebook contacts during FTE, tapping in the email field on the login screen will cause Outlook icon to show up briefly.

Repro Steps:
1) Updated Buri to BuildID: 20140116040206
2) Launch FTE
3) Hit "Next" button until Import Contacts screen
4) Select to import Facebook contacts
5) Tap the email field

Actual:
The Outlook icon is showing up briefly

Expected:
Outlook icon shouldn't show up when importing Facebook contacts

Environmental Variables:
Device: Buri v1.4 Master Build, Mozilla RIL
BuildID: 20140116040206
Gaia: 82878ba16172213cd00ba3e8b377564b290e59c1
Gecko: 324e2cba1029
Version: 29.0a1
Firmware Version: v1.2-device.cfg

Notes: the issue doesn't reproduce on v1.3, only 1.4 is affected

Repro frequency: 100%
See video of the issue - http://youtu.be/MBEKue4XW4o
(Reporter)

Updated

4 years ago
status-firefox28: --- → unaffected
(Reporter)

Updated

4 years ago
Summary: [B2G][FTE] Outlook icon is showing up briefly when tapping on email field in the Facobook log in screen → [B2G][FTE] Outlook icon is showing up briefly when tapping on email field in the Facebook log in screen

Comment 1

4 years ago
.:First Broken Build:.
Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20131211040203
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Gecko: 12ea03a70243
Version: 29.0a1
Firmware Version: v1.2-device.cfg

.:Last Working Build:.
Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20131210040206
Gaia: c952e2756c03eceb4de6a3eba15651741a62f9e8
Gecko: df82be9d89a5
Version: 29.0a1
Firmware Version: v1.2-device.cfg
Keywords: regressionwindow-wanted
QA Contact: gbennett
Looks like a window management bug - there's UI showing that's not part of the FTE showing when it shouldn't be as part of the pop-up.
blocking-b2g: --- → 1.4?
Component: Gaia::First Time Experience → Gaia::System::Window Mgmt
(In reply to Jason Smith [:jsmith] from comment #2)
> Looks like a window management bug - there's UI showing that's not part of
> the FTE showing when it shouldn't be as part of the pop-up.

Oh and - nominating mainly because of the fact that FTE UX has to be solid.
Triage: must fix regression in 1.4 cycle.

Alive, please help.
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(alive)
Assignee: nobody → alive
Flags: needinfo?(alive)
On it.
Created attachment 8381271 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/16605

The root cause is popup manager get wrong size.

We should move popup into appwindow to avoid this but for this stage let's modify statusbar.
I also remove 4 invalid tests because StatusBar.element is polluted by someone and let's tack them back in System2 Statusbar.
Attachment #8381271 - Flags: review?(timdream)
Comment on attachment 8381271 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/16605

It seems to me we are not solid enough on height calculation. We should be able to do more on 1.5.

(Travis-CI failed BTW)
Attachment #8381271 - Flags: review?(timdream) → review+
Travis Fixed

https://github.com/mozilla-b2g/gaia/commit/21dec4d9f7597aa676aee91074958cd49a1f4fec
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v1.4: --- → fixed
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.