Firefox crash in igd10iumd32.dll within mozilla::layers::CompositorD3D11::BeginFrame

RESOLVED INCOMPLETE

Status

()

defect
--
critical
RESOLVED INCOMPLETE
5 years ago
2 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({crash, steps-wanted, topcrash-metro})

Trunk
x86
Windows 8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28+ fixed, firefox29+ fixed, firefox30 fixed, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

(Whiteboard: [metro] [release28] [gfx] [leave-open] [Intel HD Graphics Drivers for Windows 8(R)] r=ff28, crash signature)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-1ddcb8aa-558e-43d9-b766-9a0b02140113.
=============================================================

This is the #2 topcrash in MetroFirefox 28.0a2 and 29.0a1.  For more reports, see https://crash-stats.mozilla.com/report/list?signature=igd10iumd32.dll%400xbc69

According to crash-stats, this signature first appeared on 2013-10-24.  All the reports are from Windows 8.1, which was released around that time, so maybe this is a new crash in 8.1 (or maybe the signature just changed).
Hi Milan, can you take a look at this bug for inclusion in the FF28 release.
Flags: needinfo?(milan)
Whiteboard: [metro] [defect] [gfx] [triage] → [metro] [defect] [gfx]
Whiteboard: [metro] [defect] [gfx] → [metro] [beta28] [gfx]
It seems to consistently crash in this call:
mContext->ClearRenderTargetView(mDefaultRT->mRTView, black);
inside of BeingFrame, with a null pointer.  Is it possible that mDefaultRT is ok, but mRTView inside of it is null?
(Nick, I know not what I speak of, but how come we needed the scissoring set, when the ClearRenderTargetView docs say that it's ignored for D3D10/11)
Flags: needinfo?(ncameron)
Flags: needinfo?(milan)
Flags: needinfo?(bas)
I'm afraid these are both questions for Bas, sorry. I'm not really sure how we use scissoring on Windows.
Flags: needinfo?(ncameron)
We were already checking mDefaultRT, so I'm adding a check for the view as well.
Attachment #8363110 - Flags: review?(bas)
Comment on attachment 8363110 [details] [diff] [review]
avoid null views

Review of attachment 8363110 [details] [diff] [review]:
-----------------------------------------------------------------

Shouldn't really ever happen! But let's see what it does, do note that this will mostly just cause severe rendering artifacts instead of a crash. Which of the two is better is an interesting question.
Attachment #8363110 - Flags: review?(bas) → review+
Flags: needinfo?(bas)
https://hg.mozilla.org/mozilla-central/rev/aa978f40963a
Assignee: nobody → jmathies
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
No longer blocks: metrov1backlog

Updated

5 years ago
Whiteboard: [metro] [beta28] [gfx] → [metro] [beta28] [gfx] [01-24 Nightly]
Comment on attachment 8363110 [details] [diff] [review]
avoid null views

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unknown
User impact if declined: crashy app
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8363110 - Flags: approval-mozilla-aurora?
Still seeing this. Something else is going wrong.

https://crash-stats.mozilla.com/report/index/1fa7f745-587f-411e-8b4d-a30772140126
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

5 years ago
Keywords: topcrash-metro

Updated

5 years ago
Whiteboard: [metro] [beta28] [gfx] [01-24 Nightly] → [metro] [beta28] [gfx] [leave-open]

Updated

5 years ago
Assignee: jmathies → nobody

Updated

5 years ago
Attachment #8363110 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Whiteboard: [metro] [beta28] [gfx] [leave-open] → [metro] [beta28] [gfx] [leave-open] [Intel HD Graphics Drivers for Windows 8(R)]

Updated

5 years ago
Keywords: needURLs
Hey Asa, I remember you had some friends over at intel when you were on the metro team. Curious if you might be able to ping them and have a look at this crash? It's our current #1 top crasher in metrofx, and is happening in a intel driver.
Flags: needinfo?(asa)
(In reply to Jim Mathies [:jimm] from comment #9)
> Hey Asa, I remember you had some friends over at intel when you were on the
> metro team. Curious if you might be able to ping them and have a look at
> this crash? It's our current #1 top crasher in metrofx, and is happening in
> a intel driver.

email sent. good luck!
Flags: needinfo?(asa)
Updating status then to reflect, while investigation continues.  Asa - any response from Intel?
Flags: needinfo?(asa)
(In reply to Lukas Blakk [:lsblakk] from comment #12)
> Updating status then to reflect, while investigation continues.  Asa - any
> response from Intel?

They need str, which we don't have yet. They are following this bug.
Flags: needinfo?(asa)
URLs are kind of all over the place (scrubbed for privacy):
Total Count 	URL
1 	https://play.google.com/music/listen#/album//Margaret+Marshall/Handel%3A+Messiah+-+Highlights
1 	https://cau.uca.es/software.cgi?SID=...
1 	https://www.facebook.com/
1 	https://mail.google.com/mail/u/0/#inbox
1 	http://forums.creative.com/showthread.php?t=699661&page=3
1 	http://cn.bing.com/search?q=Dynamics+Sure+Step&pc=MOZI&form=MOZSBR
1 	http://www.yudkin.com/sampleplan.htm
1 	http://facebook.com/
1 	about:newtab
1 	http://www.piciforms.de/
1 	http://www.tube8.com/anal/anjelica/18110572/
1 	http://www.kinox.to/
1 	http://www.reddit.com/
1 	https://www.amazon.co.uk/gp/buy/thankyou/handlers/display.html?...
1 	http://winsupersite.com/windows-8/mozilla-ships-modern-version-firefox
1 	http://www.princesspolly.com.au/Bad-Dress.aspx?p54992
1 	http://www.xnxx.com/
1 	http://www.sonyalpharumors.com/
1 	http://memebase.cheezburger.com/
1 	http://www.tangthuvien.vn/forum/showthread.php?t=103899&page=99
1 	http://orderchaosonline.com/
1 	http://www.escapistmagazine.com/videos/view/escape-to-the-movies/8771-The-Lego-Movie
1 	http://grooveshark.com/#!/s/Move+Along/1r4RlT?src=5
1 	http://www.el3aby.com/3409
1 	http://www.eurosport.fr/football/premier-league/2013-2014/arsene-wenger-arsenal-taxe-les-propos-de-jose-mourinho-chelsea-de-stupides_sto4139494/story.shtml
1 	http://www.quickmath.com/webMathematica3/quickmath/equations/solve/basic.jsp#c=solve_stepssolveequation...
1 	https://www.paypal.com/us/webapps/mpp/credit-card-reader-faq
1 	http://www.wi1.uni-muenster.de/pi/lehre/ws0506/se/uebungen.php
1 	https://us-mg6.mail.yahoo.com/neo/launch?...
1 	http://www.gov.im/categories/planning-and-building-control/planning-development-control/levels-of-development-which-can-be-done-without-planning-permission/
1 	https://www.google.com.au/url?q=http://www.applepirobotics.org/wp-content/uploads/...
1 	http://apps.microsoft.com/windows/en-us/app/super-bowl-xlviii-nfl-official/...
1 	http://www.couchtuner.eu/psych/
1 	https://archive.org/
1 	http://forums.ocworkbench.com/showthread.php?t=156093

There's only one comment in crash-stats:
"Waking my desktop up after it went to sleep."

Kamil, can you see if you can try to reproduce this?
Flags: needinfo?(kamiljoz)
Keywords: needURLssteps-wanted
QA Contact: kamiljoz

Updated

5 years ago
Crash Signature: [@ igd10iumd32.dll@0xbc69] [@ mozilla::layers::CompositorD3D11::BeginFrame(nsIntRegion const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const *,gfxMatrix const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gfx::RectTyp… → [@ igd10iumd32.dll@0xbc69] [@ igd10iumd32.dll@0x91dcc] [@ mozilla::layers::CompositorD3D11::BeginFrame(nsIntRegion const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const *,gfxMatrix const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> …

Updated

5 years ago
Summary: Metro Firefox crash in igd10iumd32.dll@0xbc69 within mozilla::layers::CompositorD3D11::BeginFrame → Metro Firefox crash in igd10iumd32.dll within mozilla::layers::CompositorD3D11::BeginFrame

Updated

5 years ago
Crash Signature: [@ igd10iumd32.dll@0xbc69] [@ igd10iumd32.dll@0x91dcc] [@ mozilla::layers::CompositorD3D11::BeginFrame(nsIntRegion const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const *,gfxMatrix const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> … → [@ igd10iumd32.dll@0xbc69] [@ igd10iumd32.dll@0x91dcc] [@ igd10iumd32.dll@0xb799] [@ mozilla::layers::CompositorD3D11::BeginFrame(nsIntRegion const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const *,gfxMatrix const &,mozilla::gfx::RectTyped<…
I'm going through this right now and will try to see if I can reproduce the crash using some the links provided in comment #14.

Comment 16

5 years ago
Intel has released 10.18.10.3412 drivers for Haswell and Ivy Bridge. Can someone test the latest drivers and see if Intel has fixed this?

32bit
https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23638

64bit
https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23639
I'm seeing 13 reports across all branches in the last week. While that might not be enough to call this fixed I think we can safely say this is no longer a top-crash. Unfortunately there's not much more we can say given that we've been unable to identify any steps to reproduce this.

@GMA, we don't have steps to reproduce so we won't be able to say one way or another whether the new drivers make a difference.
Flags: needinfo?(kamiljoz) → needinfo?(mbrubeck)
Matt, do you think we can close this bug report (or at least untrack it) based on comment 17?
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #17)
> I'm seeing 13 reports across all branches in the last week. While that might
> not be enough to call this fixed I think we can safely say this is no longer
> a top-crash. Unfortunately there's not much more we can say given that we've
> been unable to identify any steps to reproduce this.
> 
> @GMA, we don't have steps to reproduce so we won't be able to say one way or
> another whether the new drivers make a difference.

AFAICT this is still our #2 top crasher on fx28, #3 in nightly. I don't think this is fixed at all.

Comment 20

5 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #17)
> I'm seeing 13 reports across all branches in the last week. While that might
> not be enough to call this fixed I think we can safely say this is no longer
> a top-crash.

This is on Metro, we have very few users and therefore crashes there, so be careful with statements like this.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #20)
> This is on Metro, we have very few users and therefore crashes there, so be
> careful with statements like this.

Yes, you are right. Sorry about the disconnect. Looking at this again it appears this is the #1 top crash across all Metro versions. This should block releasing Metro in Firefox 28 in my opinion. This is quite concerning given that we are more than half way through the Beta cycle. What do we need to make progress on this?
Flags: needinfo?(mbrubeck)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #21)
> (In reply to Robert Kaiser (:kairo@mozilla.com) from comment #20)
> > This is on Metro, we have very few users and therefore crashes there, so be
> > careful with statements like this.
> 
> Yes, you are right. Sorry about the disconnect. Looking at this again it
> appears this is the #1 top crash across all Metro versions. This should
> block releasing Metro in Firefox 28 in my opinion. This is quite concerning
> given that we are more than half way through the Beta cycle. What do we need
> to make progress on this?

I don't think it needs to block. We need to get out to release to increase the user base. Without that tracking down crashes without str is hard.

Milan, any chance we might get some help in looking at this from gfx?
Flags: needinfo?(milan)
(In reply to Jim Mathies [:jimm] from comment #22)
> I don't think it needs to block. We need to get out to release to increase
> the user base.

First impressions being important as they are, if we release Metro v1 with a high-volume crash you'll drive people away.

Kamil, can you please make finding steps to reproduce this bug a top priority?
Flags: needinfo?(kamiljoz)

Updated

5 years ago
Flags: needinfo?(milan)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #23)
> (In reply to Jim Mathies [:jimm] from comment #22)
> > I don't think it needs to block. We need to get out to release to increase
> > the user base.
> 
> First impressions being important as they are, if we release Metro v1 with a
> high-volume crash you'll drive people away.
> 
> Kamil, can you please make finding steps to reproduce this bug a top
> priority?

I agree here and I'll spend some time on this today since the gfx team is currently tied up in other work.

As far as blocking rollout goes though I still don't think this qualifies. Our crash per adu ratio is around ~2.5% (on par with desktop which is around 1.5%) and this ratio includes crashes due to bug 962140 which represent 31.65% of crashes and should be fixed in b6.

(Granted desktop has 2,854,670 adus and metrofx only has 550 :) so our data has a lot more noise, but still it's what we have to go on.)

Comment 25

5 years ago
(In reply to Jim Mathies [:jimm] from comment #24)
> Our crash per adu ratio is around ~2.5% (on par with desktop which is around
> 1.5%)

Please don't call rates in "crashes / 100 ADI" a percentage as it isn't (it's a ratio not much unlike miles per gallon or so).
It should certainly be a P1 and if we can figure out how to reproduce it, it should probably be a blocker too. I am hesitant to make it an outright blocker if we have no way to confirm and test it though. If we can't reproduce it and identify the cause, it makes it very difficult to say if we fixed it.  I do agree a crashy release is not a good first impression and not what we want/need for metro's introduction, but I think we need more data before we can really make the blocker call.

With the note about crashing on wake from sleep (comment 14), I wonder if it is related to the driver reset bug we had for D2D a while back too.
Kamil, can you please take another crack at trying to reproduce this on a Windows 8.1 32-bit device running Intel GPU drivers? Perhaps using it for a couple hours, letting it sleep overnight, and resuming it in the morning, and repeating will uncover something. I think it would be useful to keep trying to reproduce this until we're faced with the go-no-go deadline, or until Jim and the GFX comes up with something.
I noticed something interesting, all of these appear to come in on a paint call for the top level icore window. Generally we don't get a lot of WM_PAINTs since we paint with layers and everything is presented via d3d, so we don't do any invalidation on the win32 window.

Not sure what would cause this. We trigger paints manually when the window is first displayed and for window activation events. Playing around with that though (hitting the windows key repeatedly with fx in the foreground) didn't cause any problems.
So maybe we should just get rid of our WM_PAINT handling. AFAICT NeedsWidgetInvalidation always returns false for our environment, so we don't invalidate the window and as such, should need to handle WM_PAINTS. Although this might be incorrect, maybe we want these in certain cases (driver resets maybe, which I don't understand).

http://dxr.mozilla.org/mozilla-central/source/gfx/layers/client/ClientLayerManager.h#89

Testing with this on a surface pro, I don't see any side effects.
Attachment #8383091 - Flags: feedback?(bas)
I've tried to reproduce this issue, but without success (no crashes), on a win 8.1 64-bit machine, with Intel HD 2500 GPU and CPU: Inter(R) Core(TM) i5-3470 CPU @ 3.20GHz 3.50GHz, using the 29.0a1 Nightly from 2014-01-24 (build ID: 20140124030216).

I've tried the following:

1) loaded and browsed through all sites mentioned in comment 14
2) while the sites from 1) were loaded, I've switched several times between Desktop and Metro mode
3) left the PC to "sleep" for a while and then continued browsing
Blocks: metrobacklog
No longer blocks: metrov1omtc&apzc
Comment on attachment 8383091 [details] [diff] [review]
nix wm_paint handling in winrt widget

Review of attachment 8383091 [details] [diff] [review]:
-----------------------------------------------------------------

I feel this is an improvement.
Attachment #8383091 - Flags: feedback?(bas) → feedback+
Comment on attachment 8383091 [details] [diff] [review]
nix wm_paint handling in winrt widget

Review of attachment 8383091 [details] [diff] [review]:
-----------------------------------------------------------------

Lets land this and see if there's any negative fallout.
Attachment #8383091 - Flags: review?(netzen)
Attachment #8383091 - Flags: review?(netzen) → review+
Whiteboard: [metro] [beta28] [gfx] [leave-open] [Intel HD Graphics Drivers for Windows 8(R)] → [metro] [beta28] [gfx] [leave-open] [Intel HD Graphics Drivers for Windows 8(R)] r=ff30

Updated

5 years ago
Flags: needinfo?(jmathies)
Comment on attachment 8383091 [details] [diff] [review]
nix wm_paint handling in winrt widget

[Approval Request Comment]
Bug caused by (feature/regressing bug #): long standing issue. 
User impact if declined: crashy browser.
Testing completed (on m-c, etc.): yes.
Risk to taking this patch (and alternatives if risky): potential rendering issues.
String or IDL/UUID changes made by this patch: none

Our coverage on mc isn't great, we have twice the number of users on aurora, so I'd like to uplift this to get better coverage. If it looks like a good fix, we'll uplift to beta as well in a few days.
Attachment #8383091 - Flags: approval-mozilla-aurora?

Comment 37

5 years ago
Jim, given that our coverage on Aurora is pretty small as well and Beta is nearing the end, I wonder if it's better to get this into Beta right away.

Note that the beta build being created today is the last beta build of this cycle and on Monday we are building the release builds as "RCs" already, so time on Beta is *very* short. Because of that, IMHO we need to either get this into beta before go-to-build today (and have a chance of a backout before Monday's go-to-build in case something blows up) or we don't get it into 28 at all.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #37)
> Jim, given that our coverage on Aurora is pretty small as well and Beta is
> nearing the end, I wonder if it's better to get this into Beta right away.
> 
> Note that the beta build being created today is the last beta build of this
> cycle and on Monday we are building the release builds as "RCs" already, so
> time on Beta is *very* short. Because of that, IMHO we need to either get
> this into beta before go-to-build today (and have a chance of a backout
> before Monday's go-to-build in case something blows up) or we don't get it
> into 28 at all.

Ok, sounds good. Lets get it into beta. I feel pretty comfortable uplifting.
Flags: needinfo?(jmathies)

Comment 39

5 years ago
Comment on attachment 8383091 [details] [diff] [review]
nix wm_paint handling in winrt widget

Adding approval request for beta as well per jimm's comment, risk/reward assessment is identical to the aurora approval request.
Attachment #8383091 - Flags: approval-mozilla-beta?

Comment 40

5 years ago
Oh, and btw, I did a query for crashes with this signature on nightly and couldn't see any in the last week with a build newer than 2/14. That's way before the patch landed, but at least also none since then.

Beta has 5-10 crashes of this kind on most days, so we probably need to land there to see if it really help anyhow.
Attachment #8383091 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8383091 [details] [diff] [review]
nix wm_paint handling in winrt widget

Approved also for beta (checked with Lukas)
Attachment #8383091 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-aurora/rev/595710593981
https://hg.mozilla.org/releases/mozilla-beta/rev/44da198d98de

Marking this as fixed on the branches for tracking purposes. Feel free to set back to affected if future patches need uplift as well.
Whiteboard: [metro] [beta28] [gfx] [leave-open] [Intel HD Graphics Drivers for Windows 8(R)] r=ff30 → [metro] [release28] [gfx] [leave-open] [Intel HD Graphics Drivers for Windows 8(R)] r=ff28
Flags: needinfo?(kamiljoz)

Comment 44

5 years ago
Here's the latest Intel 10.18.10.3496 drivers if anyone wants to test it.

32bit
https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23713

64bit
https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23714
Target Milestone: mozilla29 → ---

Comment 45

5 years ago
my firefox constantly crashes with same error message. Last time it happen when i was on http://www.epichardcore.com/ and http://www.xvideos.com/
I am tryed to reinstall flash player, but looks like the problem still exists. What to do?
(In reply to hellover2 from comment #45)
> my firefox constantly crashes with same error message.

Please provide links to the crash reports you submitted. You will find them in about:crashes.
Issue was resolved - clearing outdated action-tags
Keywords: steps-wanted
wrong bug, sorry for the noise
Keywords: steps-wanted
I think we should probably just close this bug report since we're no longer actively supporting Metro Firefox and have no crashstats for these builds anymore.
Crash Signature: [@ igd10iumd32.dll@0xbc69] [@ igd10iumd32.dll@0x91dcc] [@ igd10iumd32.dll@0xb799] [@ mozilla::layers::CompositorD3D11::BeginFrame(nsIntRegion const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const *,gfxMatrix const &,mozilla::gfx::RectTyped<… → [@ igd10iumd32.dll@0xbc69] [@ igd10iumd32.dll@0x91dcc] [@ igd10iumd32.dll@0xb799] [@ igd10iumd32.dll@0xc3c9 ] [@ mozilla::layers::CompositorD3D11::BeginFrame(nsIntRegion const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const *,gfxMatrix con…
Duplicate of this bug: 1011867
Summary: Metro Firefox crash in igd10iumd32.dll within mozilla::layers::CompositorD3D11::BeginFrame → Firefox crash in igd10iumd32.dll within mozilla::layers::CompositorD3D11::BeginFrame
Crash Signature: [@ igd10iumd32.dll@0xbc69] [@ igd10iumd32.dll@0x91dcc] [@ igd10iumd32.dll@0xb799] [@ igd10iumd32.dll@0xc3c9 ] [@ mozilla::layers::CompositorD3D11::BeginFrame(nsIntRegion const &,mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const *,gfxMatrix con… → [@ igd10iumd32.dll@0xbc69] [@ igd10iumd32.dll@0x91dcc] [@ igd10iumd32.dll@0xb799] [@ igd10iumd32.dll@0xc3c9 ] [@ igd10iumd32.dll@0xc7e9 ] [@ igd10iumd32.dll@0x513cc ] [@ igd10iumd32.dll@0xc476c ] [@ igd10iumd32.dll@0xc039 ] [@ igd10iumd32.dll@0x9a…
Blocks: 1098655

Comment 52

4 years ago
https://crash-stats.mozilla.com/report/index/4f5accfb-dd3a-43e8-af7f-a1ffc2150204

The bug is still alive and well... 1100 crashes in the past week

I am able to reproduce it by opening two youtube tabs and playing things in each. I switch back and forth and switch videos and scroll to the comments section.  The crash happens when I scroll down past the video, to look at the comments.  Maybe the compositor is getting an illegal value for where it's supposed to put the movie?

But looking at the comments on the crash report summary page, it sounds like most people are getting the bug on suspend/resume.  Weird.

I have Intel graphics driver version 10.18.10.3277.  I tried upgrading it with Intel's driver sniffing tool, but it refused, because ASUS had a customized version of the driver.  OK, I downloaded the ....3277.01 version from the ASUS web site, and installed it, but the version number reported by Windows didn't change.  The laptop is weird, it seems to have two display adapters, an NVIDIA GeForce GT 740M and a Intel HD Graphics thing.  I've tried to upgrade both drivers, but the crashes still happen.

I could reproduce it and give you crash dumps, install alpha versions, or whatever.  Let me know.

Comment 53

4 years ago
I should add that I have to mess with youtube like that for about a minute to trigger the crash.
In the first crash I looked at, https://crash-stats.mozilla.com/report/index/4f5accfb-dd3a-43e8-af7f-a1ffc2150204, we get DXGI_ERROR_UNSUPPORTED from DrawTargetD2D::CreateRTForTexture() on a 64x309 size, while at 41% memory usage.

Suspend/resume could be driver reset.

thomathom, there is a bit more data you could get, but it gets a bit involved, so let us know if you're up to it:

* In about:config, create a new integer preference gfx.logging.level, set it to 3.
* Restart with the console redirector (https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options?redirectlocale=en-US&redirectslug=Command_Line_Options) to get access to the console output.
* Attach the output to the bug.
Bas, the crashes are 36 or older, so I'm guessing the TDR changes fixed this; Bas, looking at the code the most likely way I can see something like https://crash-stats.mozilla.com/report/index/c9cd0738-b1ca-4abb-800d-c94fb2150130  crashing with a null pointer is for the D3D11 context to be invalid.  Maybe it's worth adding a diagnostic critical error in CompositingRenderTargetD3D11::BindRenderTarget to check for valid context, still crash, but at least confirm that's what's causing it?
Flags: needinfo?(bas)
(In reply to Milan Sreckovic [:milan] from comment #55)
> Bas, the crashes are 36 or older, so I'm guessing the TDR changes fixed
> this; Bas, looking at the code the most likely way I can see something like
> https://crash-stats.mozilla.com/report/index/c9cd0738-b1ca-4abb-800d-
> c94fb2150130  crashing with a null pointer is for the D3D11 context to be
> invalid.  Maybe it's worth adding a diagnostic critical error in
> CompositingRenderTargetD3D11::BindRenderTarget to check for valid context,
> still crash, but at least confirm that's what's causing it?

I don't think that's necessary from an acute perspectve, the ECX register (which is 0x0 in this crash report), which I believe would here be set to aContext both for the function call and the vtable lookup, already confirms that.
Flags: needinfo?(bas)
So, we don't have a way of fixing this in 36, without TDR changes, so we have 8 more weeks of the crashes?

Comment 58

4 years ago
I did as you said with the gfx.logging.level and the console, but I wasn't able to make it crash anymore :(

It did give several of these messages, which are suggestive, but I'm not sure if it's the same thing that happens when it crashes.

###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xAA0001,name=PTexture::Msg
___delete__) Route error: message sent to unknown actor ID

Comment 59

4 years ago
Got one!

I'm not sure how much of it was right when the crash happened.  Unfortunately, there are no timestamps?  This was preceded by a bunch of the PTexture::Msg lines that I pasted above. 

1424312552050   addons.update-checker   WARN    Update manifest for {972ce4c6-7e
08-4474-a285-3208198ce6fd} did not contain an updates property
1424312552166   addons.update-checker   WARN    Update manifest for web2pdfexten
sion@web2pdf.adobedotcom did not contain an updates property
Can't find symbol '_Z35eglQueryStringImplementationANDROIDPvi'.
console.error: reddit_res:
  Message: TypeError: workers[i].tab is null
  Stack:
    getActiveWorker@resource://gre/modules/addons/XPIProvider.jsm -> jar:file://
/C:/Users/Jessica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-1422
772650658/extensions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource:/
/gre/modules/commonjs/toolkit/loader.js -> resource://jid1-xufzosoflzsoxg-at-jet
pack/reddit_res/lib/main.js:128:8
@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Jessica/A
ppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-1422772650658/extension
s/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/modules/common
js/toolkit/loader.js -> resource://jid1-xufzosoflzsoxg-at-jetpack/reddit_res/lib
/main.js:118:15
_emitOnObject@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Us
ers/Jessica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-1422772650
658/extensions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/m
odules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/depreca
ted/events.js:153:9
_emit@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Jess
ica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-1422772650658/exte
nsions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/modules/c
ommonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/deprecated/even
ts.js:123:12
_emitEvent@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users
/Jessica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-1422772650658
/extensions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/modu
les/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/windows/ta
bs-firefox.js:135:5
_onTabEvent@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/User
s/Jessica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-142277265065
8/extensions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/mod
ules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/windows/t
abs-firefox.js:124:7
_emitOnObject@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Us
ers/Jessica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-1422772650
658/extensions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/m
odules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/depreca
ted/events.js:153:9
_emit@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Jess
ica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-1422772650658/exte
nsions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/modules/c
ommonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/deprecated/even
ts.js:123:12
onTabSelect@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/User
s/Jessica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-142277265065
8/extensions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/mod
ules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/tabs/obse
rver.js:60:14
_emitOnObject@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Us
ers/Jessica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-1422772650
658/extensions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/m
odules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/depreca
ted/events.js:153:9
_emit@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Jess
ica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-1422772650658/exte
nsions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/modules/c
ommonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/deprecated/even
ts.js:123:12
handleEvent@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/User
s/Jessica/AppData/Roaming/Mozilla/Firefox/Profiles/dr2annoo.default-142277265065
8/extensions/jid1-xUfzOsOFlzSOXg@jetpack.xpi!/bootstrap.js -> resource://gre/mod
ules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/tabs/obse
rver.js:48:5
updateCurrentBrowser@chrome://browser/content/tabbrowser.xml:1145:15
onselect@chrome://browser/content/browser.xul:1:44
set_selectedIndex@chrome://global/content/bindings/tabbox.xml:652:13
set_selectedPanel@chrome://global/content/bindings/tabbox.xml:671:13
set_selectedIndex@chrome://global/content/bindings/tabbox.xml:399:15
set_selectedItem@chrome://global/content/bindings/tabbox.xml:431:34
set_selectedTab@chrome://global/content/bindings/tabbox.xml:110:15
set_selectedTab@chrome://browser/content/tabbrowser.xml:2528:11
_blurTab@chrome://browser/content/tabbrowser.xml:2202:13
removeTab@chrome://browser/content/tabbrowser.xml:1917:13
onxblclick@chrome://browser/content/tabbrowser.xml:4755:1

[14048] ###!!! ABORT: Aborting on channel error.: file c:/builds/moz2_slave/rel-
m-rel-w32_bld-000000000000/build/ipc/glue/MessageChannel.cpp, line 1508


That last line was when I killed Firefox.
This no longer shows up in topcrash reports. All told there are 2 crashes with Firefox 41.0 and 2 crashes with Firefox 40.0.3 reported. Given this information I am resolving the bug as incomplete. Please reopen if you think this is an issue we can/should be concerned about.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → INCOMPLETE

Comment 61

2 years ago
I get similar error when I am trying to watch video from http://videos.apornstories.com/
How to upload here crash report?
If you go to about:crashes, you will see a list of links to the recent crashes you had.

Comment 63

2 years ago
O meu firefox não está salvando minhas senhas corretamente, ele ta bugado já desinstalei e instalei novamente mais não to conseguindo arrumar. https://videosdesuavizinha.com/
You need to log in before you can comment on or make changes to this bug.