Closed Bug 960703 Opened 7 years ago Closed 5 years ago

Manifest icon not used for synthesized APK in Android 2.3

Categories

(Firefox for Android :: Web Apps (PWAs), defect, P3)

ARM
Android
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
fennec - ---

People

(Reporter: aaronmt, Unassigned)

Details

(Whiteboard: [WebRuntime])

Attachments

(1 file)

http://penguinpop.justplaymobile.com/penguinpop.webapp

{
  "version": "1.0",
  "name": "Penguin Pop",
  "description": "Penguin Pop is a fun an very addicting whack a Penguin game style. You must tap the penguins, fish and igloos when they pop up from underneath the ice.",
  "icons": {
    "16": "http://www.justplaymobile.com/html5games/mozilla/penguinpop/img/icon-16.png",
    "48": "http://www.justplaymobile.com/html5games/mozilla/penguinpop/img/icon-48.png",
    "128": "http://www.justplaymobile.com/html5games/mozilla/penguinpop/img/icon-128.png"
  },
  "launch_path": "/",
  "developer": {
    "name": "TweenSoft Inc.",
    "url": "http://www.tweensoft.com"
  },
  "installs_allowed_from": [
    "https://marketplace.firefox.com"
  ],
  "locales": {
    "es": {
      "description": "Pingüino Pop es un divertido un golpe muy adictivo estilo de juego Penguin. Debe tocar en los pingüinos, peces y iglúes cuando hacen estallar para arriba por debajo del hielo."
    },
    "it": {
      "description": "Pinguino Pop è un divertimento un molto avvincente whack uno stile di gioco Penguin. È necessario toccare l', pinguini e pesci igloo quando pop-up da sotto il ghiaccio."
    }
  },
  "default_locale": "en",
  "fullscreen": "true",
  "orientation": "portrait"
}

http://dapk.net/application.apk?manifestUrl=http%3A%2F%2Fpenguinpop.justplaymobile.com%2Fpenguinpop.webapp

On my HTC One (Android 2.3), I get a standard no-icon green Android icon for the installed web-application.

Testing the same on my LG Nexus 4 (Android 4.4.2), it doesn't seem to have this issue.
tracking-fennec: ? → -
Please nom for web-app experience in web app triage
Flags: needinfo?(myk)
(In reply to Aaron Train [:aaronmt] from comment #1)
> Please nom for web-app experience in web app triage

Will do!


jhugman: do you have a 2.3 device you can use to reproduce and investigate this bug?
Flags: needinfo?(myk)
Still reproducible.
Martyn & James: do either of you have a 2.3 device you can use to reproduce and investigate this bug?
Flags: needinfo?(mhaigh)
Flags: needinfo?(jhugman)
I do have a 2.3 device but I'm in the US and as such don't have the device with me.  I'll have access after the 21st.  Maybe someone else in the MV or SF office will have access to one?
Flags: needinfo?(mhaigh)
Priority: -- → P3
SV o(In reply to Myk Melez [:myk] [@mykmelez] from comment #4)
> Martyn & James: do either of you have a 2.3 device you can use to reproduce
> and investigate this bug?

Tested on HTC Desire HD (Android 2.3.5), the issue is reproducing. I've attached the logcat. Please ask for more info or further investigation if needed.
Attached file noicon_webapp_logcat
I wonder if this is the same as bug 982814.
Whiteboard: [WebRuntime]
This is occurring on the Nexus One (Gingerbread) and the Nexus 7 (KitKat).

The fix is to ensure that there is always a drawable-hdpi asset available.
Assignee: nobody → jhugman
Flags: needinfo?(jhugman)
Requesting needinfo as proxy for review of PR <https://github.com/mozilla/apk-factory-service/pull/62>.
Flags: needinfo?(ozten.bugs)
I left some questions and feedback in the PR.
Flags: needinfo?(ozten.bugs)
jhugman: the PR can't be merged anymore.  Can you update it?  (And respond to ozten's questions and feedback, if you haven't already!)
Flags: needinfo?(jhugman)
Flags: needinfo?(jhugman)
Assignee: jhugman → nobody
Per bug 1235869, we're going to disable the Android web runtime, so we won't fix this bug in it.

(This is part of a bulk resolution of bugs in the Firefox for Android::Web Apps component, from which I attempted to exclude bugs that are not specific to the runtime, but it's possible that I included one accidentally.  If so, I'm sorry, and please reopen the bug!)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.