test_ev_certs.js: failingOCSPResponder doesn't fail properly

RESOLVED FIXED in mozilla29

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: keeler, Assigned: keeler)

Tracking

unspecified
mozilla29
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Without setting the server's identities to "www.example.com" and "crl.example.com", it will just return 400 (bad request) to any requests made to these hosts, and it will not run the registered prefix handler that causes the test to fail. Fixing this also uncovered an issue in the case where the EE cert doesn't have an OCSP url; it turns out libpkix will make an OCSP request for the intermediate before getting to the EE.
Created attachment 8361298 [details] [diff] [review]
960723-failingOCSPResponder.diff
Assignee: nobody → dkeeler
Status: NEW → ASSIGNED
Attachment #8361298 - Flags: review?(brian)
Comment on attachment 8361298 [details] [diff] [review]
960723-failingOCSPResponder.diff

Review of attachment 8361298 [details] [diff] [review]:
-----------------------------------------------------------------

I guess you could say...
(•_•)
( •_•)>⌐■-■
(⌐■_■)
I don't know how to write code that fails.
Attachment #8361298 - Flags: review?(brian) → review+
My only response is this: http://mirrors.rit.edu/instantCSI/ (requires flash, unfortunately. Maybe I'll make an html5 one...)
Thanks for the quick review.
https://hg.mozilla.org/integration/mozilla-inbound/rev/a2d581209387
https://hg.mozilla.org/mozilla-central/rev/a2d581209387
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
You need to log in before you can comment on or make changes to this bug.