Closed Bug 960811 Opened 6 years ago Closed 6 years ago

enable synthetic APKs by default in Fennec builds

Categories

(Firefox for Android :: Web Apps, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox29 --- verified
relnote-firefox --- 29+

People

(Reporter: myk, Assigned: myk)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch enable synthetic APKs (obsolete) — Splinter Review
Once we update Fennec to download APKs from the APK Factory development server (bug 960207), we should enable synthetic APKs by default in Fennec builds.

Here's a patch that does that by setting MOZ_ANDROID_SYNTHAPKS in mobile/android/confvars.sh, which is similar to the way we enable "NFC permission" by setting MOZ_ANDROID_BEAM in that file.  But some other features with compile-time flags are enabled directly in configure.in; let me know if I should do that instead.

I'd like to commit this on Tuesday, January 21, so synthetic APKs make it into Fennec's nightly builds starting Wednesday, January 22.
Attachment #8361376 - Flags: review?(mark.finkle)
Comment on attachment 8361376 [details] [diff] [review]
enable synthetic APKs

I am fine with this approach
Attachment #8361376 - Flags: review?(mark.finkle) → review+
Cool, thanks mfinkle.

Note: I'm still going to hold off committing this until Tuesday, January 21.
(In reply to Wes Kocher (:KWierso) from comment #4)
> I had to back this out in
> https://hg.mozilla.org/integration/mozilla-inbound/rev/f5c17b4a4199 because
> it broke Android: 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=33421158&tree=Mozilla-
> Inbound

I'm not sure this failure is related, although the other two were definitely caused by this change.  I filed bug 962858 to figure them out.
(In reply to Myk Melez [:myk] [@mykmelez] from comment #5)
> (In reply to Wes Kocher (:KWierso) from comment #4)
> > I had to back this out in
> > https://hg.mozilla.org/integration/mozilla-inbound/rev/f5c17b4a4199 because
> > it broke Android: 
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=33421158&tree=Mozilla-
> > Inbound
> 
> I'm not sure this failure is related, although the other two were definitely
> caused by this change.  I filed bug 962858 to figure them out.

Hrm, all three showed up on your push, and stayed there until my backout, and then showed back up together on this later push: https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=b89f28d7f0f9&jobname=android%202.2%20armv6
(In reply to Wes Kocher (:KWierso) from comment #6)
> Hrm, all three showed up on your push, and stayed there until my backout,
> and then showed back up together on this later push:
> https://tbpl.mozilla.org/?tree=Mozilla-
> Inbound&rev=b89f28d7f0f9&jobname=android%202.2%20armv6

And then they're gone again in the next push?
(In reply to Wes Kocher (:KWierso) from comment #7)
> (In reply to Wes Kocher (:KWierso) from comment #6)
> > Hrm, all three showed up on your push, and stayed there until my backout,
> > and then showed back up together on this later push:
> > https://tbpl.mozilla.org/?tree=Mozilla-
> > Inbound&rev=b89f28d7f0f9&jobname=android%202.2%20armv6
> 
> And then they're gone again in the next push?

I suspect the build system doesn't know that it needs to rebuild files using MOZ_ANDROID_SYNTHAPKS in preprocessor directives when the value of that configuration flag changes, so here's a version of the patch that touches CLOBBER when it enables synthetic APKs.

This is still blocked on the test failures, so it is not ready for commission until the blocker bug is resolved.
Attachment #8361376 - Attachment is obsolete: true
Attachment #8364397 - Flags: review?(mark.finkle)
Attachment #8364397 - Flags: review?(mark.finkle) → review+
Depends on: 962858
Here's a try run with the patch from bug 960811 also applied:

https://tbpl.mozilla.org/?tree=Try&rev=327cc714d889
The try run looks good, and I just pushed bug 960811 to Inbound.  Assuming it sticks, I'll repush this tomorrow (Sunday, January 26) to enable synthetic APKs on Monday's nightly build.
(In reply to Myk Melez [:myk] [@mykmelez] from comment #10)
> The try run looks good, and I just pushed bug 960811 to Inbound.

Erm, I meant to say that I pushed bug 962858 to Inbound.  And it did indeed stick, which is why I pushed this bug to Inbound today, which should mean it gets to Central in time for tomorrow's nightly build (as long as sheriffs do an Inbound -> Central merge this evening).
https://hg.mozilla.org/mozilla-central/rev/0a9af08f037f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.