Switching keyboard layout may reveal homescreen and the previous keyboard

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: rudyl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [3rd-party-keyboard])

STR
===
1. Launch keyboard and make sure it has multiple layouts (languages) enabled.
2. Press the globe key to switch to the next layout.

   Result: the homescreen would be seen for a short time and then the previous keyboard layout is shown first then the keyboard layout we want.

Expected:
   Switching correctly without flicker.


This is similar to Bug 958035 and the root cause might be the same, but I'll just file it for tracking.
See Also: → bug 958035
Duplicate of this bug: 964979

Comment 2

4 years ago
Can be reproduce on v1.4 flame and Dolphin.

Updated

4 years ago
blocking-b2g: --- → 1.4?
Cosmetic problem - no functional impact.
blocking-b2g: 1.4? → 2.1?
I can't reproduce this on 2.1, might be already fixed by bug 1022475. qawanted to verify.
Keywords: qawanted
I'm unable to reproduce this issue on Flame 2.1 master, Buri 2.0, Flame 1.4, and Buri 1.3.

Observed on 2.1 and 2.0: I don't see a globe icon (described in original STR) for changing keyboard languages, and when changing keyboard languages I don't see any abnormal UI. Key layouts are promptly changed. Tested in Messages app.

Observed on 1.4 and 1.3: Globe icon is present in keyboard, but I don't see anything unusual when pressing on it multiple times. Key layouts are promptly changed. Tested in Messages app.

Device: Flame
Build ID: 20140723121905
Gaia: 15c84c943e41ad834640a45e1e1c2ac804168af7
Gecko: 30907d52c4c2
Version: 34.0a1 (Master)
Firmware Version: v122

Device: Buri
Build ID: 20140723152707
Gaia: 91986777d0942b63e37fbfeec19d69d6176d6d74
Gecko: 392054b2e899
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame
Build ID: 20140723075714
Gaia: 6e4eaa5befce9c1812e07bcc78b2138645bdbe7a
Gecko: 2d16ba0b45bc
Version: 30.0 (1.4)
Firmware Version: v122

Device: Buri
Build ID: 20140721151227
Gaia: 23f55be856cef53c6604a6fe4aeb09061afbc897
Gecko: 9727017eabb9
Version: 28.0 (1.3)
Firmware Version: v1.2device.cfg

-----------

Not setting tracking flags because I've not seen this bug repro on any device/branch.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted

Comment 6

4 years ago
unable to reproduce, Comment 5, close this bug.
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
You need to log in before you can comment on or make changes to this bug.