timeStamp attribute in progress-event gives nanoseconds instead milliseconds

RESOLVED DUPLICATE of bug 238041

Status

()

RESOLVED DUPLICATE of bug 238041
5 years ago
5 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

(Blocks: 1 bug)

26 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I'm doing a form-upload and added a progress-eventlistener:

xhr.upload.addEventListener('progress', function(ev) {
    console.log([ev.timeStamp, new Date().getTime()])
}, false);



Actual results:

Output on console:
[1389961044736000, 1389961044736]

timeStamp seems to be nanoseconds for (at least) this event instead of milliseconds.



Expected results:

on console:
[1389961044736, 1389961044736]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 238041
You need to log in before you can comment on or make changes to this bug.