Closed Bug 96109 Opened 18 years ago Closed 18 years ago

img alt attribute text doesn't display on mouseover

Categories

(SeaMonkey :: General, defect)

x86
Windows NT
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 25537

People

(Reporter: casper, Assigned: asa)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

The alt text doesn't display on mouseover.  This used to work, and does
work in IE and NS.
This is not the broken image problem, as the images display fine, and
everything else works great.
Tiny can't find any errors in the HTML I've included.

Reproducible: Always
Steps to Reproduce:
1.Load included HTML.
2.Move mouse over where the image would be.
3.Rename some random gifs to load in place of the buttons to show
that it's not the broken image alt bug.

Actual Results:  No alt "tool tip" text

Expected Results:  display text

<html>
<head>
  <title>PBC Clerk EIP Web Search - Document Viewer Toolbar</title>
</head>

<body background="images/blue_bar.gif" bgcolor="#0067A7">
  <table border=0 align="center" cellpadding=0 cellspacing=0><!-- ** Begin
Toolbar Buttons, 1 row ** -->
    <tr valign="top">
      <td width="20">

      </td>
      <td width="5">&nbsp;</td>
      <td width="20">

          <a
href="viewframes.jsp?pid=75+2+DL8+libsrvrx36+Clerk+Research%3Blibsrvrx%3BPBC_Document19+16+H%24GN4QQZCKH0GYDD&page=1&scale=0.6160000000000001&rotation=0"
target="_parent">
          <img src="images/icoZoomIn.gif" alt="Zoom In (62%)" width=32 height=32
border="0" align=left hspace=0 vspace=0>
          </a>

      </td>
      <td width="20">

          <a
href="viewframes.jsp?pid=75+2+DL8+libsrvrx36+Clerk+Research%3Blibsrvrx%3BPBC_Document19+16+H%24GN4QQZCKH0GYDD&page=1&scale=0.5090909090909091&rotation=0"
target="_parent">
          <img src="images/icoZoomOut.gif" alt="Zoom Out (51%)" width=32
height=32 border="0" align=left hspace=0 vspace=0>
          </a>

      </td>
      <td width="20">

          <a
href="viewframes.jsp?pid=75+2+DL8+libsrvrx36+Clerk+Research%3Blibsrvrx%3BPBC_Document19+16+H%24GN4QQZCKH0GYDD&page=1&scale=0.56&rotation=0"
target="_parent">
          <img src="images/icoZD.gif" alt="Default Zoom (56%)" width=32
height=32 border="0" align=left hspace=0 vspace=0>
          </a>

      </td>
      <td width="5">&nbsp;</td>
      <td width="20">

          <a
href="viewframes.jsp?pid=75+2+DL8+libsrvrx36+Clerk+Research%3Blibsrvrx%3BPBC_Document19+16+H%24GN4QQZCKH0GYDD&page=1&scale=0.56&rotation=3"
target="_parent">
          <img src="images/icoRotateLeft.gif" alt="Rotate Left" width=32
height=32 border="0" align=left hspace=0 vspace=0>
          </a>

      </td>
      <td width="20">

          <a
href="viewframes.jsp?pid=75+2+DL8+libsrvrx36+Clerk+Research%3Blibsrvrx%3BPBC_Document19+16+H%24GN4QQZCKH0GYDD&page=1&scale=0.56&rotation=1"
target="_parent">
          <img src="images/icoRotateRight.gif" alt="Rotate Right" width=32
height=32 border="0" align=left hspace=0 vspace=0>
          </a>

      </td>
      <td width="20">

          <a
href="viewframes.jsp?pid=75+2+DL8+libsrvrx36+Clerk+Research%3Blibsrvrx%3BPBC_Document19+16+H%24GN4QQZCKH0GYDD&page=1&scale=0.56&rotation=2"
target="_parent">
          <img src="images/icoRotateDown.gif" alt="Rotate 180" width=32
height=32 border="0" align=left hspace=0 vspace=0>
          </a>

      </td>
      <td width="5">&nbsp;</td>
      <td width="20">

          <img src="images/BEGINgray.gif" alt="First Page" width=32 height=32
border="0" align=left hspace=0 vspace=0>

      </td>
      <td width="20">

          <img src="images/PREVIOUSgray.gif" alt="Previous Page" width=32
height=32 border="0" align=left hspace=0 vspace=0>

      </td>
      <td width="20">

          <img src="images/NEXTgray.gif" alt="Next Page" width=32 height=32
border="0" align=left hspace=0 vspace=0>

      </td>
      <td width="20">

          <img src="images/ENDgray.gif" alt="Last Page" width=32 height=32
border="0" align=left hspace=0 vspace=0>

      </td>
      <td width="5">&nbsp;</td>
	<td width="125" align="left" valign="top" nowrap>
      <form name="ViewToolbar" action="viewframes.jsp" method=get target="_parent">
	  <select name="page" onchange="this.form.submit()">

	          <OPTION selected value=1>1</OPTION>

        </select>
	  <b><font color=white>&nbsp;of 1</font></b>

            <input type="hidden" name="pid" value="75 2 DL8 libsrvrx36 Clerk
Research;libsrvrx;PBC_Document19 16 H$GN4QQZCKH0GYDD">
            <input type="hidden" name="scale" value="0.56">
            <input type="hidden" name="rotation" value="0">

      </form>
      </td>
    </tr>
  </table> <!-- ** End Toolbar Buttons, 1 row ** -->
</body>
</html>
Rick, you might as well give up.  A LOT of people, including me, have asked for
this, and every time it's come up, it's been shot down.  There is no way this
feature will ever get implemented, according to the Mozilla folks.
This is a dup of bug 25537. It has been decided not to implement ALT in
tooltips. The TITLE tag is the correct one for this. If you want to see the ALT
text in the toolip, do as in the following example:

 <img src="images/ENDgray.gif" alt="Last Page" title="Last Page"
width=32 height=32 border="0" align=left hspace=0 vspace=0>

This way you will see the same text in both Netscape 4 and Mozilla tooltip.



*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
we did not decide, the W3C did.  We are doing it per spec. Read the duped to bug
for more 
Status: RESOLVED → VERIFIED
Will add title attribute to the code.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.