Weak observers added by content-sessionStore.js may never be removed

RESOLVED DUPLICATE of bug 961106

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 961106
4 years ago
4 years ago

People

(Reporter: ttaubert, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
SessionStore's frame script adds a few weak observers that might never be removed if the corresponding notification is never being sent. Only when iterating the list of observers, invalid weak references will be removed.

We might need and API to hook into when frame scripts are destructed so that we can explicitly remove observers.
(Reporter)

Updated

4 years ago
Depends on: 961111
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 961106
You need to log in before you can comment on or make changes to this bug.