[B2G][Browser][RTSP] No error notification about a broken RTSP link

RESOLVED DUPLICATE of bug 951188

Status

Firefox OS
Gaia::Video
RESOLVED DUPLICATE of bug 951188
4 years ago
4 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun1.3-2)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8361929 [details]
Broken_link_video.ogg

Description:
When open a broken RTSP link, no any error messages pops up to notify a user that the stream is broken, the loading wheel just spinning and showing the loading process

Repro Steps:
1) Updated Buri to BuildID: 20140117004005
2) Open browser from the home screen
3) In URL type: "https://forum.videolan.org/viewtopic.php?f=13&t=115131" or find your own rtsp broken link
4) First post is providing a rtsp stream link open the link

Actual:
The loading wheel is loading the content and not notifying about the broken link

Expected:
Error message appears about video is not available

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140117004005
Gaia: a81ccdc53e45a6adeaae423e104e91bcc1e12b0e
Gecko: 2c033140eff4
Version: 28.0a2
Firmware Version: v1.2-device.cfg

Notes: This bug was created based on the test case #8111
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=8111
See attached: video clip

Updated

4 years ago
blocking-b2g: --- → 1.3?
Component: Gaia::Browser → Gaia::Video
Vincent,

Does this bug is the same as bug 951188 that you are handling now?
Flags: needinfo?(vchang)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 951188

Updated

4 years ago
blocking-b2g: 1.3? → ---
Flags: needinfo?(vchang)
You need to log in before you can comment on or make changes to this bug.