Closed Bug 961370 Opened 8 years ago Closed 8 years ago

OpenH264: crash [@WelsDec::FmoParamUpdate]

Categories

(Core :: WebRTC: Audio/Video, defect)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: posidron, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, testcase)

Crash Data

Attachments

(2 files)

Attached file callstack
Hi Christoph, this bug was found and fixed already. will pull request in time. Thanks~
root cause found, i.e., invalid Nal Packet too small so that the error handling is incorrect. 
Solution: remove the invalid Nal Packet from to-be-decoded packet list. 
pull request can be found by https://github.com/cisco/openh264/pull/167
Hi Christoph:
   fix it. Could you verify it on cisco/master branch? thanks!
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.