Can't close a malicious tab (onbeforeunload abuse)

RESOLVED DUPLICATE of bug 636374

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 636374
4 years ago
3 years ago

People

(Reporter: David, Unassigned)

Tracking

26 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

This tab cannot be closed by any means.

http://policia.es.id203948203948203948.p250632.com/




Actual results:

The tab can't be closed.


Expected results:

The tab should close.

Comment 1

4 years ago
Several versiosn of this web page exists.

http://polfed-fedpol.be.id481796243-2232736469.k769943.com/?flow_id=9022&173897=69893/case_id=75540

The only way to close this page is to:

Comment 2

4 years ago
It seems that several versions of this web page exists

http://polfed-fedpol.be.id481796243-2232736469.k769943.com/

The only ways i found to get rid of this page is to hit the "Quit" button like a hundred times or to kill the firefox process.

The Greasymonkey script "Disable - remove onbeforeunload" (https://userscripts.org/scripts/show/121551) don't work in this case.

Strictly speaking this is not a Firefox bug, but, like said in the title, a Javascript abuse because this can be replicated in IE too.
Flags: needinfo?

Updated

4 years ago
Flags: needinfo?
Likely a dupe of bug 950336 or bug 616853

Comment 4

4 years ago
Fixed with bug 636374.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636374
You need to log in before you can comment on or make changes to this bug.