Closed Bug 961375 Opened 6 years ago Closed 6 years ago

Label for "Hide title bar when scrolling" pref is cropped in portrait mode

Categories

(Firefox for Android :: General, enhancement)

ARM
Android
enhancement
Not set

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox27 --- unaffected
firefox28 --- verified
firefox29 --- verified
fennec 28+ ---

People

(Reporter: aryx, Assigned: Margaret)

References

Details

Attachments

(3 files)

Latest Firefox Mobile Nightly and Aurora on Android 4.1.2

The preference""Hide title bar when scrolling" currently gets cropped in portrait mode. If the state gets negate and the preference controls showing and not hiding of the titlebar, the label would fit into the available space.
Which device is it cropped for you? Can you attach a screenshot?
Attached image screenshot of issue
It's even cropped for en-US on Nexus S.
Blocks: 944925
I wonder if we could come up with a shorter title for the pref, and then use the small description text underneath to clarify what the preference does.
Flags: needinfo?(ibarlow)
Summary: negate state of preference "Hide title bar when scrolling" and drop verb (label currently cropped in portrait mode) → Label for "Hide title bar when scrolling" pref is cropped in portrait mode
tracking-fennec: --- → ?
Yeah Chrome uses a lot of android:summary for their setting and their labels are quite short
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → 28+
Gah, sorry for the delay. 

What if we just change the string to "Scroll title bar"?
Flags: needinfo?(ibarlow)
Attached patch patchSplinter Review
That sounds like a fine solution to me.
Attachment #8367016 - Flags: review?(bnicholson)
flod, is this the type of change we would uplift for a late-l10n fix, or should we just let it ride the trains? I was debating whether or not to just make this an en-US fix, but I worry that localizers might have equally long labels in their locales.
Flags: needinfo?(francesco.lodolo)
Attachment #8367016 - Flags: review?(bnicholson) → review+
I'd say:
1. Let the patch adding a new string ride the trains, it's way too late for Aurora
2. Fix only the en-US string (no new ID, just update the string content) on Aurora/Beta and send a warning on dev-l10n about this issue, so that localizers can take action is they want. A string cut only in portrait mode is better than an English string everywhere, in case they don't have time to localize it.

Ideally they should have caught it during QA, some locales did for sure (e.g. French)
http://transvision.mozfr.org/string/?entity=mobile/android/base/android_strings.dtd:pref_dynamic_toolbar&repo=central

And that reminds me that I should test on a phone, not just a tablet...
Flags: needinfo?(francesco.lodolo)
Thanks for the update. Just landed the regular patch on fx-team:
https://hg.mozilla.org/integration/fx-team/rev/ba6a785bf7ea

I can whip up a patch to change only the en-US string on Aurora.
Attachment #8367370 - Flags: review?(francesco.lodolo)
Comment on attachment 8367370 [details] [diff] [review]
en-US update for aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 944925
User impact if declined: title for setting is cut off on some devices
Testing completed (on m-c, etc.): tested locally
Risk to taking this patch (and alternatives if risky): low-risk, just a string update for en-US
String or IDL/UUID changes made by this patch: consulted with flod, this patch just updates the en-US string, which won't affect localizers, but I will make a post to dev-l10n explaining the issue in case they want to update their locales
Attachment #8367370 - Flags: approval-mozilla-aurora?
Comment on attachment 8367370 [details] [diff] [review]
en-US update for aurora

Review of attachment 8367370 [details] [diff] [review]:
-----------------------------------------------------------------

Patch is good for me, thank Margaret.
Attachment #8367370 - Flags: review?(francesco.lodolo) → review+
Waiting for fx-team/central landing before approving on branch
https://hg.mozilla.org/mozilla-central/rev/ba6a785bf7ea
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Attachment #8367370 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on FF release 28 and Firefox 29 Beta 4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.