Closed Bug 961460 Opened 8 years ago Closed 6 years ago

Cannot enter username on UK National Lottery site

Categories

(Firefox for Android Graveyard :: General, defect)

24 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ian.northwood, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

- Go to www.national-lottery.co.uk
- Select the 'username' text-box
- Try to enter a username


Actual results:

The page refreshes entirely. The problem does NOT occur with the password field!


Expected results:

The on-screen keyboard should appear.
OS: Windows 8.1 → Android
Hardware: x86_64 → ARM
Blocks: 961463
Unfortunately, there's a site-restriction on accessing the sign-in from outside the UK (I'm in Canada). CC'ing Lucas or Chris to maybe take a look here to see if they can reproduce the issue.
No longer blocks: 961463
Correction: The page doesn't refresh. It looks more like the keyboard tries to pop up but is blocked somehow.

Additional info: This is FF v24 on a Samsung Galaxy S4 with Android 4.3 using the Google keyboard v1.1.1881.801980
Yes, I can't test this either. Maybe Chris Mills can?
I'm happy to test it; I've got a Samsung Galaxy S3 with 4.3 on it.

Where do I download previous builds? ;-)
ftp://ftp.mozilla.org/pub/mobile/nightly/ or if you have a python setup https://github.com/mozilla/mozregression though Mozregression uninstalls nightly so your Nightly Firefox profile will be deleted if you use that branch.
Thanks Kevin. So how do I know which one is version 24? Sorry for the n00b questions.
Check against https://wiki.mozilla.org/RapidRelease/Calendar nightly column. Though we don't know which release it may have regressed. Checking release or beta builds 14 - 30 at ftp://ftp.mozilla.org/pub/mobile/releases/ is a good way to narrow the scope.
This page produces a similar response: the keyboard pops up then immediately disappears
http://m.johnlewis.com/mt/www.johnlewis.com/#page_loaded
This is the code that breaks johnlewis.com:

    var b = d('*:focus'),
    g = window.innerHeight + 200,
    j = (new Date) .getTime();
    u ? (clearInterval(u), u = null)  : (h = !1, b.length && !l.isIE10 && (l.isAndroid2 ? setTimeout(function () {
      b[0].focus()
    }, 300)  : (b[0].blur(), setTimeout(function () {
      h =
      !0
    }, 300))), d('body') .css({
      'min-height': g + 'px'
    }), !l.isAndroid2 && !l.isIE10 && window.scrollTo(0, 1), u = setInterval(function () {
      var b = (new Date) .getTime();
      if (parseInt(document.body.clientHeight) >= g && 0 < document.body.scrollTop || 1000 < b - j) clearInterval(u),
      u = null,
      l.isAndroid || l.isIE10 ? setTimeout(q, 300)  : q()
    }, 100))

in a file named ufx.js

Comments say 
"Copyright Usablenet Inc. 2012-2013
@author Marco Brondani"

I haven't seen this ufx code before, I think - it might by coincidence also run on the lottery site, but we shouldn't bet on it. You could try to use developer tools' debugger's search feature :-)
Duplicate of this bug: 1118467
The johnlewis.com problem now tracked in bug 1139747
See Also: → 1139747
(In reply to Ian Northwood from comment #8)
> This page produces a similar response: the keyboard pops up then immediately
> disappears
> http://m.johnlewis.com/mt/www.johnlewis.com/#page_loaded

I founded the same problem here https://www.lavishshoestring.com
when i want to checkout in basket.
this problem only in mozilla.
(In reply to lotosmerega from comment #12)
> I founded the same problem here https://www.lavishshoestring.com
> when i want to checkout in basket.

Hi, where exactly do you see this problem? I added a random item to the shopping basket and filled out name and address without issues. Tested in Firefox release on Windows.
[cough]
[quote]Additional info: This is FF v24 on a Samsung Galaxy S4 with Android 4.3 using the Google keyboard v1.1.1881.801980[unquote]
Testing Firefox 50 (Nightly) on a Samsung Galaxy J5, this seems to work fine now.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Restrict Comments: true
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.