Closed Bug 961560 Opened 6 years ago Closed 6 years ago

Create/use a SUMO topic redirect for the missing plugin URL

Categories

(Firefox for Android :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox26 --- wontfix
firefox27 --- fixed
firefox28 --- fixed
firefox29 --- fixed
fennec + ---

People

(Reporter: reuben, Assigned: u454397)

References

Details

(Keywords: verifyme)

Attachments

(1 file)

The missing plugin error message links to a 404 page in SUMO:

https://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/PluginHelper.js#268

This was caused because bug 702319 changed app.support.baseURL to use SUMO topic redirects like desktop does, but didn't update its users.
Ricky, can you create the mobile-flash-unsupported redirect, pointing to https://support.mozilla.org/kb/why-cant-firefox-mobile-play-flash-on-my-device ?

Margaret, can you also confirm if that's the article we want to link to?
Attachment #8362326 - Flags: review?(margaret.leibovic)
Flags: needinfo?(rrosario)
(In reply to Reuben Morais [:reuben] from comment #1)
> Ricky, can you create the mobile-flash-unsupported redirect, pointing to
> https://support.mozilla.org/kb/why-cant-firefox-mobile-play-flash-on-my-
> device ?

Done!
Flags: needinfo?(rrosario)
Comment on attachment 8362326 [details] [diff] [review]
Use a SUMO redirect in the Learn More link

Review of attachment 8362326 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for catching this. I did a quick search to check for the other places we use app.support.baseURL, and the only other place we point to a specific article is for the telemetry link in bug 702319, so we shouldn't need to do any more fixes.
Attachment #8362326 - Flags: review?(margaret.leibovic) → review+
Also, which versions of Firefox does this affect? Bug 702319 landed a long time ago. We should see if we can uplift this if it's currently affecting all versions.
tracking-fennec: --- → ?
Flags: needinfo?(reuben.bmo)
(In reply to :Margaret Leibovic from comment #4)
> Also, which versions of Firefox does this affect? Bug 702319 landed a long
> time ago. We should see if we can uplift this if it's currently affecting
> all versions.

All of them, it seems:

https://hg.mozilla.org/releases/mozilla-release/file/29657549d158/mobile/android/app/mobile.js#l456
https://hg.mozilla.org/releases/mozilla-release/file/29657549d158/mobile/android/chrome/content/PluginHelper.js#l273
Flags: needinfo?(reuben.bmo)
Keywords: checkin-needed
Comment on attachment 8362326 [details] [diff] [review]
Use a SUMO redirect in the Learn More link

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 702319
User impact if declined: the missing plugin error message links to a 404 page in SUMO
Testing completed (on m-c, etc.): only tested locally
Risk to taking this patch (and alternatives if risky): low-risk, changes URL for an in-product SUMO link
String or IDL/UUID changes made by this patch: none
Attachment #8362326 - Flags: approval-mozilla-beta?
Attachment #8362326 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/integration/fx-team/rev/6bbfaa5f5775
Assignee: nobody → reuben.morais
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Looks like a very low risk change, I am approving it on branches in parallel to m-c, so it can land today and get into our beta going to build soon.
Keywords: verifyme
Attachment #8362326 - Flags: approval-mozilla-beta?
Attachment #8362326 - Flags: approval-mozilla-beta+
Attachment #8362326 - Flags: approval-mozilla-aurora?
Attachment #8362326 - Flags: approval-mozilla-aurora+
tracking-fennec: ? → +
https://hg.mozilla.org/mozilla-central/rev/6bbfaa5f5775
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
You need to log in before you can comment on or make changes to this bug.