All users were logged out of Bugzilla on October 13th, 2018

Enable APZ in Firefox OS makes resize dispatched twice when 1. app starts up and 2. user rotates the device at first time

RESOLVED DUPLICATE of bug 997101

Status

()

RESOLVED DUPLICATE of bug 997101
5 years ago
a year ago

People

(Reporter: johnhu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

Created attachment 8362413 [details]
with-apz.txt

While debugging bug 831890, I found the resize event of window object will be dispatched twice at the first rotation. But after the first rotation, it is only dispatched once per rotation.

Device: Inari
Version: Master, PVT: 20140119040203
Created attachment 8362414 [details]
log without apz
Created attachment 8362420 [details]
testing app based on template app

In this testing app, it shows "please rotate your device to see result." at the screen. When user rotates the device once, it increases the resizeCount and shows "resizeCount: $1".
Created attachment 8362427 [details]
rotate with the testing app

Wihtout APZ enabled, it works correctly. After APZ enabled, we may observe:
1. the resize is called twice while app started
2. the resize is called twice when the first rotation
3. the resize is called once when the 2+ rotations.
Blocks: 831890
Summary: Enable APZ in Firefox OS makes resize dispatched twice when user rotates the device → Enable APZ in Firefox OS makes resize dispatched twice when 1. app starts up and 2. user rotates the device at first time
See Also: → bug 997101
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → All
Adding standalone testcase extracted from test app
On the latest master code, when I run the app or use the standalone test case, I see the resize called twice on app startup, but then only once all rotations. So part of this bug has already been fixed.
And the patch on bug 997101 makes the initial load only have one resize.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
See Also: bug 997101
Duplicate of bug: 997101
You need to log in before you can comment on or make changes to this bug.