"Copy" context menu action doesn't copy rich content while document in design mode (or inside container that allows to edit its content)

VERIFIED FIXED in Firefox 29

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: azasypkin, Assigned: azasypkin)

Tracking

unspecified
Firefox 29
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=0 r=ff29)

Attachments

(1 attachment)

Follow-up from bug 947505, we need to add full "copy" support for rich content while in design mode (or inside container that allows to edit its content) as it's done for "cut" action. Currently is only text content is copied. 

Steps to reproduce the issue:

1) Open Firefox Metro;
2) Load a page with document.designMode set to true. E.g. http://www.kevinroth.com/rte/demo.htm;
3) Add rich content to it. Ex. for the link above insert "Table" component;
4) Put cursor inside the document, call context menu and select "Select All" context menu action;
5) Call context menu on the selected content and select "Copy" context menu action;
6) Try to paste content copied at the previous step;
7) Only simple text content is pasted.

Current Behavior:

- Only simple text content is copied in design mode.

Expected Behavior:

- Full selected rich content should be copied. Compare paste output for "Cut" command that works as intended.
Blocks: metrobacklog
Whiteboard: [defect] p=0
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
Posted patch copy v1.diffSplinter Review
Attachment #8363128 - Flags: review?(sfoster)
Comment on attachment 8363128 [details] [diff] [review]
copy v1.diff

Review of attachment 8363128 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me. I tried a few different designMode/contenteditable/text input/non-editable scenarios and was able to cut/paste as expected. I've pushed this and the patch from bug 947505 to Try, see https://tbpl.mozilla.org/?tree=Try&rev=6fb7dcd0ecac 

We've had various test bugs surface there which failed to show up when testing locally. Lets re-trigger that 5+ times when its built and run, and call it good if its green
Attachment #8363128 - Flags: review?(sfoster) → review+
Thanks for review! All test passed on Try, so let's move patch forward.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3ea5b5cc5817
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Whiteboard: [defect] p=0 → p=0 r=ff29
Verified as fixed on latest Nightly (build ID: 20140226030202) and latest Aurora (build ID: 20140226004001) using a Surface Pro 2 device with the STR from the description.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.