Closed Bug 961731 Opened 6 years ago Closed 6 years ago

[v1.3] Language key button is not displayed in keyboard, after adding a new keyboard language in settings

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: viorela, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. launch Settings app 
2. tap Keyboards -> selected keyboards -> add more keyboards
3. tap Espanol keyboard checkbox
4. launch Contacts app -> tap Add contact
5. Tap Name textbox

Expected results: 
Keyboard is displayed and also the language key button

Actual results, 
Keyboard is displayed, without the language key button

This is happening intermittently. It also fails on Jenkins: http://qa-selenium.mv.mozilla.com:8080/view/B2G%20Hamachi/job/b2g.hamachi.mozilla-aurora.ui/18/HTML_Report/?
 
Device: Hamachi
Gecko  http://hg.mozilla.org/releases/mozilla-aurora/rev/37ec3c7fb511
Gaia  63cc8ffd6f2acdce14eb8285e8822ebe62fcab41
BuildID 20140120004002
Version 28.0a2
Attached image screenshot.png
Screenshot of the issue
Summary: Language key button is not displayed in keyboard, after adding a new keyboard language in settings → [v1.3] Language key button is not displayed in keyboard, after adding a new keyboard language in settings
I cannot reproduce this fail on desktop b2g, so it's a device only problem.
Blocks: 960579
From doing manual testing on device only, what's the reproduction rate of this bug?
Keywords: qawanted, regression
I can't reproduce this fail manually
Keywords: qawanted
(In reply to Viorela Ioia [:viorela] from comment #4)
> I can't reproduce this fail manually

Now, or did you mean originally, too?  It's not clear, since the steps from comment 0 are manual, but Jenkins is mentioned too.
AndreiH can you re-test this and report back, close the bug if appropriate?
Flags: needinfo?(andrei.hutusoru)
I re-tested this on the latest v1.3 build and the intermittent fail is still there [1]:

[1] https://pastebin.mozilla.org/4110542

I will start investigating this, maybe it is not a bug, and we just need some refining in our test
Flags: needinfo?(andrei.hutusoru)
I looked over this and the test on master branch had an extra method after launching Contacts [1]. My opinion is that Contacts app was launched too fast after adding a new language to keyboard.

[1] https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_change_keyboard_language.py#L30

I added this method and here are the results:

https://pastebin.mozilla.org/4111698

Updated the test in bug 960579
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.