Closed Bug 961780 Opened 6 years ago Closed 6 years ago

Handle the conflict between Firefox and b2g "browser" package

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S1 (14feb)

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

Attachments

(1 file, 2 obsolete files)

When building a "mulet" (bug 943878), we have a conflict between Firefox and b2g package both called "browser" so that we either have shell.html working or browser.xul.

A possible way to address that could be to rename b2g package. But it may break some resources from b2g/chrome/content that are expected to override default browser ones (like net/cert errors)? It may also expose unexpected resources from browser package.

There might be other ways to address that by building the mulet differently (bug 961745)
Here is a patch to rename the package to make a working mulet.
I think that's ready to land. I tried to check if any ressouce from chrome/content/*
was somehow silently overloading chrome://browser/content/ resources.
It looks like none of them actually does that.
The only that overloads existing resources from browser/ are aboutCertError and other,
and uses override rule in jar.mn.
I tried on the device and "it works". I also identified two missing images related to aboutCertError (arrows),
I added them, and you can now see them appear in cert error page (ex, on https://linuxfr.org).

But I may easily be missing something...

https://tbpl.mozilla.org/?tree=Try&rev=aff7b69540cf
Attachment #8362583 - Attachment is obsolete: true
Attachment #8370084 - Flags: review?(fabrice)
Assignee: nobody → poirot.alex
Comment on attachment 8370084 [details] [diff] [review]
Use "b2g" package name instead of "browser"

Review of attachment 8370084 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Alex, lgtm.

::: b2g/app/b2g.js
@@ +137,5 @@
>  pref("accessibility.typeaheadfind.linksonly", false);
>  pref("accessibility.typeaheadfind.casesensitive", 0);
>  
>  // pointer to the default engine name
> +pref("browser.search.defaultenginename", "chrome://b2g/locale/region.properties");

tbh I think we just don't need that pref at all for b2g.
Attachment #8370084 - Flags: review?(fabrice) → review+
Yes, it looks like defaultengine isn't really used in b2g.
The main usage of it outside of browser/ is in docshell:
  http://mxr.mozilla.org/mozilla-central/source/docshell/base/nsDefaultURIFixup.cpp#388
But b2g unset MOZ_TOOLKIT_SEARCH here:
  http://mxr.mozilla.org/mozilla-central/source/b2g/confvars.sh#55
Attachment #8370084 - Attachment is obsolete: true
Attachment #8373327 - Flags: review+
Previous try refused to execute to run gaia tests:
  https://tbpl.mozilla.org/?tree=Try&rev=f81a1bff28b3
I can't get a green Gaia ui test, but it looks like intermittents?
Failing tests are about alarms, I verified on device that we can still set an alarm.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1f36e3d0f5a7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → 1.4 S1 (14feb)
You need to log in before you can comment on or make changes to this bug.