[RFE] Change "from" email address in compose window

VERIFIED DUPLICATE of bug 87987

Status

--
enhancement
VERIFIED DUPLICATE of bug 87987
17 years ago
14 years ago

People

(Reporter: mozilla, Assigned: vparthas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

I have an entire domain, where any email to that domain reaches a single
mailbox. I also have some forwarded addresses. For those, it is impractical to
open a full blown account for each address.

On the other hand, I sometimes need to send mail from one of those addresses.
Either to change DNS on internic, answer a party that sent mail to one of my
"use once throwaway" email addresses, or any other reason.

In pine, I can simply change the From: field. Both real name and email address.

Reproducible: Always
Steps to Reproduce:
1.Click the "new mail" button
2.
3.

Actual Results:  A combo box allows me to select any of the configured email
addresses.

Expected Results:  A combo box allows me to select any of the configured email
addresses, but the result is then a plain text box that is modifyable.

It would be nice if I could also save frequently used email addresses to be
included in the combo box, despite them not being actual email addresses.

Pine also has a configuration to tell it which emails are mine, so that pressing
"reply to all" will not reply to myself.

Both of those are merely nice to have.

Comment 1

17 years ago
Would you be satisfied with, perhaps, having "Custom..." as the final item in the pop-up 
list of sender addresses? That would probably be the easiest to implement.
(Reporter)

Comment 2

17 years ago
Yes, that would be great. It does open some questions regarding "which
configuration to use".
For example - each account I have may have a different "sent-items" folder, or
even an "SMTP server" setting (the later is not the case in my situation, but
from a program functionality perspective

The proposed solution will do the trick for me, but I am wondering in terms of
overall program useability whether it will not be smarter to implement this in
the way I suggested.

Another way to implement this, which may prove easier (and then again - maybe
not) is to implement custom headers (i.e. - X-Mood: Angry, or X-Answer: 42). I
can then have a custom header called "From:", and let me override the text
placed in the original form, while still having it tied to a specific account.

Like I said, for my particular problem, simply having a "custom..." option,
sending using the default accout settings (or having a special account
specifically for that purpose) works for me.

Comment 3

17 years ago
RFE, confirming.

The behavior for validation should be constant - if the mail client requires a
valid e-mail address in account settings, it should with custom addresses also.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: I should be able to change (free form) the "from" email address → [RFE] Change "from" email address in compose window

Comment 4

17 years ago
reassigning to varada
Assignee: sspitzer → varada

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 87987 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.