Closed Bug 961802 Opened 6 years ago Closed 6 years ago

ghost-window appears on https://apprtc.appspot.com/ after selecting "Don't Share"

Categories

(Core :: WebRTC: Audio/Video, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla29
Tracking Status
firefox28 --- verified
firefox29 --- verified

People

(Reporter: florian, Assigned: jib)

References

Details

(Whiteboard: [MemShrink:P2])

Attachments

(1 file, 1 obsolete file)

Steps To Reproduce.
1. Open https://apprtc.appspot.com/ in new tab
2. In the permission prompt that appears, click "Don't Share"
3. Close the tab
4. Open about:memory and Click "Measure"
   --- observe ghost-windows
5. Click "Minimize memory usage" and Click "Measure"
   --- observe ghost-window

Actual Results:
After Step 5, this ghost-window remains:

├───12.34 MB (10.82%) -- window-objects
│   ├───5.99 MB (05.25%) ++ top(chrome://browser/content/browser.xul, id=3)
│   ├───2.36 MB (02.07%) ++ top(chrome://browser/content/hiddenWindow.xul, id=1)
│   ├───2.06 MB (01.81%) ++ top(about:memory, id=16)
│   └───1.93 MB (01.69%) -- (3 tiny)
│       ├──1.05 MB (00.92%) ++ top(about:newtab, id=29)
│       ├──0.65 MB (00.57%) -- top(none)/ghost/window(https://apprtc.webrtc.org/?r=84540542)
│       │  ├──0.62 MB (00.54%) ++ js-compartment(https://apprtc.webrtc.org/?r=84540542)
│       │  ├──0.02 MB (00.02%) ++ dom
│       │  ├──0.01 MB (00.01%) ── style-sheets
│       │  └──0.00 MB (00.00%) ── property-tables
│       └──0.23 MB (00.20%) ++ top(about:blank, id=6)
Assignee: nobody → jib
Whiteboard: [MemShrink] → [MemShrink:P2]
Blocks: 804611
Attachment #8362754 - Flags: review?(rjesup) → review+
Updated commit message. Carrying forward r+ from jesup.
Attachment #8362754 - Attachment is obsolete: true
Attachment #8363932 - Flags: review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/794bf349bb1a
Keywords: checkin-needed
OS: Mac OS X → All
Hardware: x86 → All
https://hg.mozilla.org/mozilla-central/rev/794bf349bb1a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Comment on attachment 8363932 [details] [diff] [review]
Plugged leak in getUserMedia Denied code-path (2) r=jesup

[Approval Request Comment]
Bug caused by (feature/regressing bug #): gUM permission prompt feature.
User impact if declined: Window leak. Increased cycle collection times, jank.
Testing completed (on m-c, etc.): Landed on m-c a week ago. Verified locally.
Risk to taking this patch (and alternatives if risky): Very low. Extremely simple one-line patch. No dependencies.
String or IDL/UUID changes made by this patch: None

Very similar to Bug 919244. Would be nice to address at the same time.
Attachment #8363932 - Flags: approval-mozilla-aurora?
Attachment #8363932 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Firefox 28 beta 1 (20140205162153) and latest Aurora 29.0a2 (20140205004001) under Win 7 64-bit, Ubuntu 32-bit and Mac OSX 10.8.5.
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: petruta.rasa
You need to log in before you can comment on or make changes to this bug.