[Sora][Message]The "message setting" menu should in "Messages"main screen.

RESOLVED FIXED in 1.4 S2 (28feb)

Status

Firefox OS
Gaia::SMS
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sync-1, Assigned: steveck)

Tracking

({feature})

unspecified
1.4 S2 (28feb)
feature

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
borjasalguero
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
Mozilla build ID: 20140105004001
 DEFECT DESCRIPTION:
 ->The"Setting"should in "Messages"main screen.
 
  REPRODUCING PROCEDURES:
 ->Enter"Messages"to edit a message,there is have"Setting"menu;
 
  EXPECTED BEHAVIOUR:
 ->The"Setting"should in "Messages"main screen.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:100%
 
  For FT PR, Please list reference mobile's behavior:
Actually, see UX Design attachment 8337617 [details] page 40 and 42, we should have a "settings" option in the thread list view too.

Steve, maybe you can take this bug?
blocking-b2g: --- → 1.4?
Flags: needinfo?(schung)
(Assignee)

Comment 2

4 years ago
I can take a look for sure.
Assignee: nobody → schung
Flags: needinfo?(schung)

Updated

4 years ago
Keywords: feature
(Assignee)

Comment 3

4 years ago
Created attachment 8366446 [details] [review]
Link to github

Hi Borja, I replace the icon in the thread list view and sync with thread view page. Please have a look when you have free cycle.

Hi Jose, I have a small concern about the detail. When there is no message in the app, should we enable the option icon and only shows settings in the menu? I disable option button when empty, but it also makes sense that we keep settings enable whether message exist or not.
Attachment #8366446 - Flags: review?(borja.bugzilla)
Attachment #8366446 - Flags: feedback?(vittone)
Comment on attachment 8366446 [details] [review]
Link to github

@Steve: Some comments in the PR! Ask me again to review this when you will be ready!

@Ayman: Some details are related with interaction, could you take a look? PR is https://github.com/mozilla-b2g/gaia/pull/15753 .Thanks!
Attachment #8366446 - Flags: review?(borja.bugzilla)
Flags: needinfo?(aymanmaat)

Comment 5

4 years ago
(In reply to Steve Chung [:steveck](OOO from 1/30 - 2/4) from comment #3)
> Hi Jose, I have a small concern about the detail. When there is no message
> in the app, should we enable the option icon and only shows settings in the
> menu? I disable option button when empty, but it also makes sense that we
> keep settings enable whether message exist or not.
For me it make sense. I would say that we need a [more] icon next to compose, and then show both options "Edit" and "Settings" in an option menu. 

@Ayman: What do you think?

Comment 6

4 years ago
(In reply to José Vittone from comment #5)
> (In reply to Steve Chung [:steveck](OOO from 1/30 - 2/4) from comment #3)
> > Hi Jose, I have a small concern about the detail. When there is no message
> > in the app, should we enable the option icon and only shows settings in the
> > menu? I disable option button when empty, but it also makes sense that we
> > keep settings enable whether message exist or not.
> For me it make sense. I would say that we need a [more] icon next to
> compose, and then show both options "Edit" and "Settings" in an option menu. 
> 
> @Ayman: What do you think?

fine by me, but could we call 'Edit' 'Delete' please because the user is deleting the messages, not editing them
Flags: needinfo?(aymanmaat)
(Assignee)

Comment 7

4 years ago
Comment on attachment 8366446 [details] [review]
Link to github

Hi Borja, I've updated the patch with new flow based on previous proposal for empty list case. Please have a look for the new patch and tests, thanks!
Attachment #8366446 - Flags: feedback?(vittone) → review?(borja.bugzilla)
(Assignee)

Comment 8

4 years ago
Comment on attachment 8366446 [details] [review]
Link to github

Reassign the reviewer since there has no update for week.
Hi Julien, Borja already gave some comments before, and I hope this small patch wouldn't block you for a long time...
Attachment #8366446 - Flags: review?(borja.bugzilla) → review?(felash)
Hi Steve, sorry for the delay, Im now back in Gaia so I can take this review right now (that's why I asked for rebasing the patch :) )

My only concern about this patch is that we are loosing the capacity of enabling/disabling the 'edit' button when a new message arrives. If the option menu is shown with an empty list, if a new message arrives we can not enable the button properly.

I dont know if we could hide this prompt when a new message arrives, or if we can create another OptionMenu on the fly removing the old and non-up-to-date one. Wdyt?
I think we should not show the item at all if the list is empty, and not try to add it when we receive the message. Let's keep it simple here, I don't see the value to update the menu on the fly, especially for an edge case like this.

Ayman, what do you think?
Flags: needinfo?(aymanmaat)

Comment 11

4 years ago
Hey Julien

From a UX PoV this is how i think it should work:

**PATH 1**

1) open message app to view empty inbox
2) select the list  CTA in top right hand corner
(menu presented but delete CTA is disabled)
3) incoming message arrives

**EXPECTED**
Delete CTA remains disabled.

**RATIONAL**
If the user is viewing the list presented by the CTA in the top right hand corner of the inbox at the moment that a message is incoming the user is highly unlikely to want to delete the messages straight away as they will not know the content of the message that has just been received.

—————————

**PATH 2**

1) open message app to view empty inbox
2) select the list CTA in top right hand corner
(menu presented but delete CTA is disabled)
3) close list to view empty inbox
4) incoming message arrives
5) select the list CTA in top right hand corner

**EXPECTED**
Delete CTA is now enabled.

**RATIONAL**
The user has had the chance to review the content of the incoming message and is more likely to want to delete all messages.

ni? me if you require more input
Flags: needinfo?(aymanmaat)
Perfect, thanks!
Comment on attachment 8366446 [details] [review]
Link to github

Giving the review back to Borja now that he's back ;)

Steve, if Borja is still too slow (:p) please redirect to me!
Attachment #8366446 - Flags: review?(felash) → review?(borja.bugzilla)
Thanks Julien! Re-testing and sorry (again) for the delay!
Comment on attachment 8366446 [details] [review]
Link to github

R+!
Attachment #8366446 - Flags: review?(borja.bugzilla) → review+
Target Milestone: --- → 1.4 S2 (28feb)

Updated

4 years ago
blocking-b2g: 1.4? → ---

Updated

4 years ago
blocking-b2g: --- → 1.3?

Comment 17

4 years ago
Will This bug be fixed on v1.3?
Minor bug, not a blocker for 1.3.
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.