Move aboutReader.html to /toolkit

RESOLVED DUPLICATE of bug 793920

Status

()

defect
P1
normal
RESOLVED DUPLICATE of bug 793920
5 years ago
5 years ago

People

(Reporter: eklavyamirani, Assigned: eklavyamirani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=0)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Readability parsed pages are shown in about:reader (reader mode).

As per the reviews in Bug 927124 and Bug 558882, aboutReader.html and related content should be moved to /toolkit/components/reader/
(Assignee)

Updated

5 years ago
Assignee: nobody → eklavyamirani
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 1

5 years ago
Follows after the patch in Bug 927124

I am still unsure about which css goes in toolkit and which is platform specific, so I just copied the metro one to toolkit and then overrid the entire css in toolkit with the metro one. (tested without the override, it works)
Attachment #8363235 - Flags: review?(bmcbride)
(Assignee)

Comment 2

5 years ago
Sorry for the last one, got a few things messed up there.

Moved aboutReader.html and its dependencies to toolkit
Reader mode now works on firefox desktop and metro firefox (the patch in Bug 558882 can be applied over this.)
aboutReader.css can be overriden, but assuming we need two stylesheets, I am using the default one (Not sure what needs to be in either of the stylesheets)

Strangely, if I try to load a stylesheet from the same directory as aboutReader.html, it gives me a security error. Why is that?
Attachment #8363235 - Attachment is obsolete: true
Attachment #8363235 - Flags: review?(bmcbride)
Attachment #8365708 - Flags: review?(bmcbride)
Whiteboard: p=0

Updated

5 years ago
Attachment #8365708 - Flags: review?(bmcbride)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 793920
You need to log in before you can comment on or make changes to this bug.