Closed Bug 962172 Opened 7 years ago Closed 7 years ago

Add LinkedIn to Account types.

Categories

(Participation Infrastructure :: Phonebook, defect)

2014-04.4
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: oliver.propst, Assigned: jacksonisaac2008)

Details

(Whiteboard: [kb=1329432] [mentor=giorgos@mozilla.com][lang=python][good first bug])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0 Iceweasel/24.0 (Beta/Release)
Build ID: 20130918075508

Steps to reproduce:

Login on mozillians.org.
Click the edit option in the drop-down menu.
Scroll down the page to the account list (under bio). 
Browse the available social networks in the list.


Actual results:

While you are able to add urls to a variety of social media services such as twitter and Facebook, Linkedin are missing (although you can add it as a custom url). 


Expected results:

Think it make sense to add the option to add a Linkedin url to your profile.
Great suggestion, thanks Oliver!

I suggest we validate the URL to make sure it has the proper LinkedIn profile syntax
https://www.linkedin.com/in/vanity_name
Status: UNCONFIRMED → NEW
Ever confirmed: true
Thanks, I would be happy to work on the bug.
Thanks for offering to help Oliver! I'll be happy to mentor you to submit your pull request. Please start by setting up your environment following the instructions here

http://mozillians.rtfd.org 

and then code and test your patch. Submit using a pull request against mozilla/mozillians on github when ready.

Other contributors faced some issues while building their environment today due to recent pip changes. If you face problems, we'll be happy to help you out in #commtools IRC channel on irc.mozilla.org

Good luck!
Assignee: nobody → oliver.propst
Status: NEW → ASSIGNED
Whiteboard: [mentor=giorgos@mozilla.com][lang=python][good first bug]
Version: 2014-01.1 → other
Oliver,

Are you still working on this bug? Do you need some help?
Flags: needinfo?(oliver.propst)
Have had some issues with the build environment, are trying to solve them, but feel free to take over the bug if you want (maybe its best since the bug are trivial are probably easy for you to fix).
Flags: needinfo?(oliver.propst)
Thanks for the update. You can take more time to work on this if you want. If so, please find us on IRC to solve your environment issues.
Oliver, I'll revert this bug to NEW stage so it can be available for other contributors to work on. 

Don't be discouraged though! Please find me on IRC if you have problems settings up your environments. I'll be happy to help you set it up and assign you another bug as soon as you're ready.

Thanks for offering to help!
Assignee: oliver.propst → nobody
Status: ASSIGNED → NEW
Summary: Option to add LinkedIn url to profile page are missing → Add LinkedIn to Account types.
(In reply to Giorgos Logiotatidis [:giorgos] from comment #7)
> Oliver, I'll revert this bug to NEW stage so it can be available for other
> contributors to work on. 
> 
> Don't be discouraged though! Please find me on IRC if you have problems
> settings up your environments. I'll be happy to help you set it up and
> assign you another bug as soon as you're ready.
> 
> Thanks for offering to help!

Ok, great (I'm sorry about issues I'm having).
I'm happy to take this or we can help Oliver get set up and let him have it.
(In reply to Jeff Potts from comment #9)
> I'm happy to take this or we can help Oliver get set up and let him have it.

I have mailed Giorgos details about the build issue I have.
Oliver did you manage to complete your environment setup?

If yes I'm happy to re-assign you this bug!
Flags: needinfo?(oliver.propst)
(In reply to Giorgos Logiotatidis [:giorgos] from comment #11)
> Oliver did you manage to complete your environment setup?
> 
> If yes I'm happy to re-assign you this bug!

I still have some build issues (trying to solve them using the method you told me about, have succeeded to solve some of them this way others are still present unfortunately). Do you, or any other recommend a particular GNU/Linux distribution when contributing to mozillians.org?
Flags: needinfo?(oliver.propst)
I'm using debian but any distro should do.
Hi giorgos,
I would like to start working on this as my first bug. I've completed the virtualenv installation and would like to contribute.

Thanks!
Assignee: nobody → oliver.propst
Shubham thanks for your interest. This is  something Oliver work on. Maybe you want to work on the similar bug 979825?
Status: NEW → ASSIGNED
OK no problem. I'll work on the other bug now. I had fixed this one locally but I think I shouldn't have pushed more than 1 commit...
Due to lack of activity by Oliver I'm re-assigning this bug to Jackson Isaac.

Oliver when you have the time again, ping me to get you another bug :)
Assignee: oliver.propst → jacksonisaac2008
This is a rough patch. Please review the 'url' field in TYPE_LIN.
Attachment #8402709 - Flags: review?(giorgos)
Jackson,
Thanks for sending in this patch. On mozillians.org we review code on github, directly on pull requests. Can you please pull request against mozilla/mozillians repository? Is there is a reason that you don't want to do that, please say so.
Attachment #8402709 - Flags: review?(giorgos)
Whiteboard: [mentor=giorgos@mozilla.com][lang=python][good first bug] → [kb=1329432] [mentor=giorgos@mozilla.com][lang=python][good first bug]
You are right about linkedin urls. Your profile urls can be either something like this

http://in.linkedin.com/pub/jackson-isaac/67/682/a90

or something like this

http://www.linked.com/glogiotatidis

depending on whether you've set a custom url or not.

So unfortunately we cannot use the url field of external accounts. Please leave this field empty and use the website validator to validate that users provide us with a full URL of their linkedin profile.

Thanks!
Jasckson are you still interested to finish this bug?
Flags: needinfo?(jacksonisaac2008)
Hi giorgos,

I am very much interested in finishing this bug, my college is closed for few days on account of the holy week. I will pull request my changes on github ASAP.

Sorry for the delay.
Flags: needinfo?(jacksonisaac2008)
Perfect! Let me know if you need any help :)
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Version: other → next
Verified on stage:
 * With a valid linkedin url
 * With an invalid url

Also filed bug 1000923 to convert external accounts with urls to links.
Status: RESOLVED → VERIFIED
Version: next → 2014-04.4
You need to log in before you can comment on or make changes to this bug.