PersistentRootedValue should have ValueOperations

RESOLVED DUPLICATE of bug 1107639

Status

()

defect
RESOLVED DUPLICATE of bug 1107639
6 years ago
5 years ago

People

(Reporter: soubok, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
It should be possible to write:
  JS::PersistentRootedValue foo(cx);
  foo.setObject(...);

Comment 1

6 years ago
I see that RootedValue inherits ValueOperations through the specialization of RootedBase in Value.h. Doing something analogous here ('PersistentRootedBase', perhaps?) seems like it would be appropriate. I don't have time at the moment to do it myself, but I'd gladly review a patch.
Blocks: 773686

Updated

5 years ago
OS: Windows XP → All
Hardware: x86 → All
This should not transitively block us from closing Exact Rooting. Moving it to GC.stability for now, although it's not a great fit there.
Blocks: GC.stability
No longer blocks: 773686
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1107639
You need to log in before you can comment on or make changes to this bug.