Closed Bug 962183 Opened 7 years ago Closed 7 years ago

Remove all calls to shell.html via getMostRecentWindow("navigator:browser")

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 963239

People

(Reporter: ochameau, Unassigned)

References

Details

While running b2g in a firefox tab, various code in b2g/ and dom/ are accessing shell object from shell.js via Services.wm.getMostRecentWindow("navigator:browser").
Such code is throwing as the top level window is now the firefox window instead of shell.Html.

We need to find a better way to connect these codes.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 963239
You need to log in before you can comment on or make changes to this bug.