Disable <input type=number> for v28

VERIFIED FIXED in Firefox 28

Status

()

defect
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: jwatt, Assigned: jwatt)

Tracking

({dev-doc-needed})

Trunk
mozilla28
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox27 unaffected, firefox28+ verified, firefox29 unaffected, firefox30 unaffected, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 unaffected)

Details

Attachments

(1 attachment)

The localization story <input type=number> for v28 is not sorted out, so I think we should disable it for v28.
Posted patch patchSplinter Review
Attachment #8363290 - Flags: review?(bugs)
Attachment #8363290 - Flags: review?(bugs) → review+
Comment on attachment 8363290 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 946398
User impact if declined: real potential for <input type=number> breakage on non-English sites
Testing completed (on m-c, etc.): N/A (leaving on on m-c)
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8363290 - Flags: approval-mozilla-aurora?
Attachment #8363290 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/86e7292e66d2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Backed out for causing failures in tests that expected this to be enabled and don't have fallbacks for it not being so.
https://hg.mozilla.org/releases/mozilla-aurora/rev/27713189accc

https://tbpl.mozilla.org/php/getParsedLog.php?id=33631985&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=33630132&tree=Mozilla-Aurora
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Are we going to get a patch for this soon? It's uplift day.
Flags: needinfo?(jwatt)
Actually, I think it would be better to wait until after v23 goes to b1. We could do with the extra exposure for at least one round of beta so that we have a better chance of fixing any issues in v29 before it too goes to beta (at which point it would most likely be to late and we'd end up knocking the release back to v30).
Flags: needinfo?(jwatt)
Lukas, you relnote'd input[type=number] in Bug 930277 for 28+ while this bug aims to disable it for 28. This is a heads-up ping.
Flags: needinfo?(lsblakk)
This is currently enabled in 28 though, correct?   Johnathan what's the plan for getting this disabled wrt the tests that broke in comment 4?
Flags: needinfo?(lsblakk) → needinfo?(jwatt)
Also, 29 is on Aurora now but you mention shipping this in 30 so should we mark affected on 29 too?
The intention is for this to release in v29. When I mentioned v30 what I meant to say was that I thought keeping the pref on in v28 until the first beta of v28 is released would help us find issues sooner, reducing the chances of having to put release back to v30 because if we find issues earlier we have a better chance of fixing them on aurora (in v29).
Flags: needinfo?(jwatt)
Comment on attachment 8363290 [details] [diff] [review]
patch

[Triage Comment]
This needs to be disabled in 28 now that we've merged, moving the approval to beta branch.
Attachment #8363290 - Flags: approval-mozilla-aurora+ → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/3f5b33434978

I also disabled the number Marionette test so it doesn't fail.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Backed out for landing on relbranch instead of default:

https://hg.mozilla.org/releases/mozilla-beta/rev/bb19d6aea785

Relanded on default:

https://hg.mozilla.org/releases/mozilla-beta/rev/5251d57dc768
Keywords: verifyme
Depends on: 973344
This patch did not remove the pref in b2g/app/b2g.js and mobile/android/app/mobile.js.  Is that expected?
Flags: needinfo?(jwatt)
Yes, the pref is staying on there.
Flags: needinfo?(jwatt)
Verified several pages that use input type="number" under Win 7 64-bit, Ubuntu 13.04 32-bit and Mac OSX 10.8.5 using Firefox 28 beta 4 (20140218122424) - the feature is disabled. 
(I've checked first that it was enabled on Firefox 28 beta 1.)
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: petruta.rasa
Just so I understand correctly: currently <input type="number"> is disabled on Firefox 28 and earlier (on desktop) but is enabled in Firefox 29 Desktop (currently in Aurora) and in Firefox 30 Desktop (currently in Nightly). (And it is planned to ride the train with these versions?)

Is this correct?

(In the future could you please add dev-doc-needed on such bugs? If already written, like here, we need to update "Fx XY for developers". Thank you!)
Keywords: dev-doc-needed
Correct. And will do, sorry!
You need to log in before you can comment on or make changes to this bug.