Closed Bug 962352 Opened 7 years ago Closed 7 years ago

[Sora][Message]MS prompt new message edit interface by tap home key.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P1)

defect

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S2 (28feb)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: sync-1, Assigned: alive)

Details

Attachments

(2 files)

Firefox 1.3   Mozilla build ID: 20140105004001
 DEFECT DESCRIPTION:
 ->MS prompt the message edit interface.
 
  REPRODUCING PROCEDURES:
 ->Enter"Messages" to create a message;
 ->Tap"Setting"icon to enter message settings list;
 ->Tap home key back to idle;
 
  EXPECTED BEHAVIOUR:
 ->Should back to idle normally.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:100%
 
  For FT PR, Please list reference mobile's behavior:
Can reproduce this issue both on 1.3 and master build, a video of this bug can be found here:

http://www.youtube.com/watch?v=CoXmjqeSajU&feature=youtu.be

Dear Julien, mind taking a look at this one?
Flags: needinfo?(felash)
I think this is the expected behavior: the "home" button is escaping the current activity.

Alive, can you confirm ?
Flags: needinfo?(felash) → needinfo?(alive)
Is message settings an inline activity now?
If so, it's intentional.

We plan to keep the inline activity when back to home but not implemented yet.
Flags: needinfo?(alive)
Nope, this is a "window" activity, see [1].

Is it still intentional?

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/manifest.webapp#L36-L42
Flags: needinfo?(alive)
Bug :)
Assignee: nobody → alive
Flags: needinfo?(alive)
Component: Gaia::SMS → Gaia::System::Window Mgmt
We need to find out if this reproduces on a 1.1 Buri build or not.
needinfo for comment 6
Flags: needinfo?(sync-1)
In Buri 1.1, UI flow of Message app is different from 1.3. In Buri 1.1, there is no "Setting Icon" while creating a SMS, hence cannot follow the reproduce step to reproduce this issue
Flags: needinfo?(sync-1)
Attached image Screenshots for this PR
blocking-b2g: --- → 1.3?
Discussed via Vance - there's agreement now this isn't a blocker.
blocking-b2g: 1.3? → backlog
Dears,
 
 Mozilla will not fixed this pr on v1.3. They have marked it as backlog.
 
 BRs,
 TIAN Min
Dear Jason, 

There is a flash of home screen before it calls up SMS/MMS editing interface, that makes the behavior of home key operation unpredictable to user.

Is it ok to solve this bug in v1.4?
Flags: needinfo?(vchen)
Flags: needinfo?(jsmith)
Alive is working on this, so it has a good chance of getting fixed in 1.4.
Flags: needinfo?(jsmith)
Nice to hear this good news, thanks.
Flags: needinfo?(vchen)
blocking-b2g: backlog → 1.4?
triage: 1.4+ considering the home button behavior is unexpected in this case
blocking-b2g: 1.4? → 1.4+
The root cause is:
Settings app is launched as an window disposition activity and it does postError/postResult while it's closed by home button. We should not reopen the activity caller when the callee is not active.
One line patch coming.
Comment on attachment 8381209 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/16598

r+ if this is the only way to tell whether or not callee should be launched.

We need to manually test this more to see if the behavior would be considered as a regression in other places.
Attachment #8381209 - Flags: review?(timdream) → review+
Settings -> Keyboard works
Gallery -> Email works
https://github.com/mozilla-b2g/gaia/commit/49312fb89b90eca48a8011b94a1a1a751daf32d2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.