Closed Bug 962363 Opened 8 years ago Closed 8 years ago

Start generating an additional build daily for Buri at 8am in Taipei's timezone

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jsmith, Assigned: aki)

References

Details

Attachments

(1 file, 1 obsolete file)

Background

In the QA work week, we realized that we can a lot of value if we have two builds generated per day - one at the time we currently generate a Buri build at + a build at 8am in Taipei's timezone. The reasoning for this is that we currently invest resources to do on device UI automation twice a day, so having the ability to test on distinct builds for each automation run gets a lot of value to catch bugs quicker.

Build Needs Summary

Device: Hamachi
Types: Production & Engineering
Branches: 

* Central
** https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-hamachi/
** https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-hamachi-eng/
* Aurora
** https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-aurora-hamachi/
** https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-aurora-hamachi-eng/
* Any b2g-specific branch built in 1.3 or later
** Example - mozilla-b2g28_v1_3-hamachi
8am Taipei appears to be 4pm PST.
Attached patch mc-nightly (obsolete) — Splinter Review
This will run *all* m-c b2g nightlies at 0402 and 1602 PST.
Assignee: nobody → aki
Attachment #8363393 - Flags: review?(catlee)
Duplicate of this bug: 937511
Oh, I missed the other branches in comment 0.
Attached patch multinightlySplinter Review
This is going to cause significantly more load, since it will launch all b2g nightlies on 3 branches.
Attachment #8363393 - Attachment is obsolete: true
Attachment #8363393 - Flags: review?(catlee)
Attachment #8363840 - Flags: review?(catlee)
Attachment #8363840 - Flags: review?(catlee) → review+
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
something is in production! :)
Followup fix is in production.
There is a problem with the builds now (presume caused by this).

It is picking up new Gecko changes but not the latest Gaia(git) changes.

New Taipei timezone build:
<project name="gaia.git" path="gaia" remote="mozillaorg" revision="09064f43116d1b965cb3ab6516fa0f1fa3c98a4c"/>

https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-hamachi-eng/2014/01/2014-01-30-16-02-00/sources.xml

Usual PST timezone build  - this one has the same Gaia commit 
<project name="gaia.git" path="gaia" remote="mozillaorg" revision="09064f43116d1b965cb3ab6516fa0f1fa3c98a4c"/>

https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-hamachi-eng/2014/01/2014-01-31-04-02-02/sources.xml
Aki - Any ideas on what's causing comment 10?
Flags: needinfo?(aki)
That's bug 966251, no?
Flags: needinfo?(aki)
(In reply to Aki Sasaki [:aki] from comment #12)
> That's bug 966251, no?

Ah okay. That sounds right.
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.