Closed Bug 962380 Opened 6 years ago Closed 6 years ago

[DSDS] When SIM 2 is primary outgoing call, dialing out emergency call under airplane mode will not successfully turn off airplane mode.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 verified, b2g-v1.3T fixed, b2g-v1.4 fixed)

VERIFIED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- verified
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: echu, Assigned: eragonj)

References

Details

(Whiteboard: dsdsrun1.3-2 [FT:RIL] [ETA:2/11])

Attachments

(3 files)

Attached file time stamp: 9:41, 1/22
When SIM 2 is primary outgoing call, dialing out emergency call under airplane mode will not successfully turn off airplane mode.


* Build Number  
Fugu
Gaia      ee25b0e45649d2955f340ce4f71ad55712dd0fab
Gecko     913cf2b92845441c9578787362ddad6f2ac15df6
BuildID   20140121095108
Version   28.0a2

* Reproduce Steps
1. Set SIM 2 as primary outgoing call.
2. Enable airplane mode
3. Dial 911

* Expected Result
Call can be dailed out and airplane mode will be off.

* Actual Result
Call can be dailed out and airplane mode will NOT be off. UI is still in airplane mode. Unable to MT call to SIM1 but can call to SIM 2.

* Occurrence rate
100%
Whiteboard: dsdsrun1.3-2 → dsdsrun1.3-2 [FT:RIL]
Hi Aknow, 

I verified this bug in fugu no mater on gaia master or v1.3. I have checked deeper and I found that if we set SIM1 as primary outgoing call (no matter by default or set by user manually), when dialing out 911, mozMobileConnections[0] & mozMobileConnections[1] would got `radiostatechange`. 

But if we set SIM2 as primary outgoing call, only mozMobileConnections[1] would receive this `radiostatechange`. 

Right now I use mozMobileConnectinos[0] to detect this change from Gecko by default (I know this will not work in DSDS structure with only SIM2 inserted, there is already a bug talking about this and I will fix this at that bug). 

Can you check why there is only SIM2 can receive this event in the scenario (I think this is the root cause, because both mozMobileConnections have to receive this event for sure) ? Thanks :)
Flags: needinfo?(szchen)
Offline discussed it with EJ.

Currently, we will only receive the 'radiostatechange' from the mobileconnection corresponding to the default outgoing SIM. That means only the radio of that SIM is enabled. Maybe we will have a modification for this part to enable the radio of both sim at the same time.
Flags: needinfo?(szchen)
blocking-b2g: 1.3? → 1.3+
After asking Hsin-Yi, it seems that we can handle this part on Gaia. I'll take this bug first.
Assignee: nobody → ejchen
Component: RIL → Gaia::Settings
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #3)
> After asking Hsin-Yi, it seems that we can handle this part on Gaia. I'll
> take this bug first.

It looks like Gaia bug cannot be fixed unless bug 963467 is fixed first?
Flags: needinfo?(ejchen)
Yes Tim, we need Gecko's help for this bug.
Flags: needinfo?(ejchen)
PM triage: Stays as a blocker
EJ,
Could we have an ETA for getting this patch landed on 1.3? 
Just mark ETA date on the whiteboard. example-> ETA:2/7
Can we get ETA to fix this bug? Thank you.
Ivan just discussed with me about this bug. Because this bug depends on Gecko's bug (bug 963467), I would set the ETA for Gaia side after asking Gecko about possible ETA. 

And also, if possible, I can provide Gaia patches here before Gecko if it is allowed. But we still need more testings to make sure they all work well. 

Thanks all.
After flashing gaia/master, Bug 946778 would influence the way we get radioState from mozMobileConnections. Check this line (http://goo.gl/K8GpK4) and your adb log, you would notice that this `undefined` function would make Gecko not able to receive `system-message-listener-ready` event and start doing radio related operations. 

There is already a bug talking about undefined getDataStores() function on bug 967414. 

Just want to note down all related problems here.
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #10)
> After flashing gaia/master, Bug 946778 would influence the way we get
> radioState from mozMobileConnections. Check this line (http://goo.gl/K8GpK4)
> and your adb log, you would notice that this `undefined` function would make
> Gecko not able to receive `system-message-listener-ready` event and start
> doing radio related operations. 
> 

Just to be clear, this would cause Gecko unable to return right radioState and the reason why 1.3 can get radioState correctly is because bug 946778 is not uplifted in v1.3. While in master, we would face this problem if we want to access radioState to enable airplane mode.
Hi Anshul, 

can you help me test whether this bug would happen there ? 

If yes, can you apply two related patches (one is on master while another one is on v1.3) to test whether they can fix the problem or not ? 

Thanks !! :)
Flags: needinfo?(anshulj)
Whiteboard: dsdsrun1.3-2 [FT:RIL] → dsdsrun1.3-2 [FT:RIL] [ETA:2/11]
Hi all, I just tested these two patches on our side in DSDS scenario. Here comes the long testing results and hope this can help Anshul and the others dig into the problems.

https://gist.github.com/EragonJ/44ebccdf47376b285957

Thanks.
Inder,

Please have QC test
Flags: needinfo?(ikumar)
Preeti -- talked to Anshul and he or one of his team members will provide update here.
Flags: needinfo?(ikumar)
(In reply to Inder from comment #17)
> Preeti -- talked to Anshul and he or one of his team members will provide
> update here.

Thanks Inder and Preeti !
Flags: needinfo?(anshulj) → needinfo?(mschwart)
Hi Jason, 

I noticed that its dependent bug 963467 has been marked as POVB, I dont think the estimated ETA is ok at this moment. 

Should we change the ETA or remove any flag ?


Thanks !
Flags: needinfo?(jsmith)
We probably should change the ETA - it needs to be reflective of when our partner will have this implemented.
Flags: needinfo?(jsmith)
Should we consider removing this blocker bug since its depending bug is POVB and does not have ETA for the implementation? Or do we just wait for QC test result and resolve it with the patch that works in QC test?
(In reply to Ivan Tsay (:ITsay) from comment #21)
> Should we consider removing this blocker bug since its depending bug is POVB
> and does not have ETA for the implementation? Or do we just wait for QC test
> result and resolve it with the patch that works in QC test?

We can't. The work required here is on our side (Gaia), but we need an underlying partner implementation to be able to test this. So we're blocked by our partner right now.
The patch is helping but the issue remains.  It might be our issue though.  I'll get back to you asap.
Flags: needinfo?(mschwart)
You guys changed the airplane mode API on us ;)  When we integrate then this works.
(In reply to Michael Schwartz [:m4] from comment #24)
> You guys changed the airplane mode API on us ;)  When we integrate then this
> works.

Hi Michael, I can't get it here. Can you tell more details about this part ? Thanks !
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #25)

Don't worry about it; I was just whining ;)  Your change appears to work so r+ from me.
(In reply to Michael Schwartz [:m4] from comment #26)
> (In reply to EJ Chen [:eragonj][:小龍哥] from comment #25)
> 
> Don't worry about it; I was just whining ;)  Your change appears to work so
> r+ from me.

Thanks Michael !! It's a good news by the way.
Hi Ken, this patch seems ok at QRD based on Michael's comment 25, 

should I ni? somebody to do following tests to make sure why Fugu is not able to work ? 

Thanks !!
Flags: needinfo?(kchang)
EJ - What's blocking getting the Gaia patch landed here? Trying to understand what's blocking the resolution of this bug.
Flags: needinfo?(ejchen)
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #28)
> Hi Ken, this patch seems ok at QRD based on Michael's comment 25, 
> 
> should I ni? somebody to do following tests to make sure why Fugu is not
> able to work ? 
Sam, when will you fix Bug 963467? After fix Bug 963467, can you please also verify this patch in fugo device?
Flags: needinfo?(kchang) → needinfo?(sam.hua)
(In reply to Jason Smith [:jsmith] from comment #29)
> EJ - What's blocking getting the Gaia patch landed here? Trying to
> understand what's blocking the resolution of this bug.

Hi Jason, 

basically gaia patch is ready and got verified by Michael (with QRD). But we still can't verify this patch works or not on our own devices (You can check Ken's comment #30). 

I tested our own devices with this patch and made a testing report two weeks ago.(https://gist.github.com/EragonJ/44ebccdf47376b285957)


Thanks.
Flags: needinfo?(ejchen)
yes, it can turn off the airplane.
but there is the problem of should be fixed in Bug 974580
Flags: needinfo?(sam.hua)
Comment on attachment 8370578 [details] [review]
patch on v1.3

Arthur, 

I think this patch is ready to review, please help me take a look ! thanks :)
Attachment #8370578 - Flags: review?(arthur.chen)
Comment on attachment 8370577 [details] [review]
patch on master

Arthur, 

I think this patch is ready to review, please help me take a look ! thanks :)
Attachment #8370577 - Flags: review?(arthur.chen)
Comment on attachment 8370577 [details] [review]
patch on master

r=me with the nits addressed, thanks!
Attachment #8370577 - Flags: review?(arthur.chen) → review+
Comment on attachment 8370578 [details] [review]
patch on v1.3

r=me with the nits addressed, thanks!
Attachment #8370578 - Flags: review?(arthur.chen) → review+
Comment on attachment 8370578 [details] [review]
patch on v1.3

Hi Fabrice, this bug is v1.3 blocker and need your approval.

The reason why we need this change is because we didn't bind related event on another mozMobileConnetion to catch event from Gecko. And after testing on QRD (Michael's comment) & Fugu (Sam.hua's comment), gaia change is ok and works well for them. 

Btw, we already had related tests for this behavior and that's why there is no unit test in this patch.
Attachment #8370578 - Flags: approval-gaia-v1.3?(fabrice)
Attachment #8370578 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
Thanks all, patches were landed on :

Gaia/master : 4bb8b32d8f1a3a64bfac8f2da7878dc63e613ca5
Gaia/v1.3 : 9b29f80309212bd80fbdcf2882458b1ae8b30093
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified on fugu
Gaia      f692ee0e21ef4e25ec501d60226aa7da4b06ae60
Gecko     fcf711bbb0affff0925cb133c82073998bb46abf
BuildID   20140306041555
Version   28.0

Yet a big problem that UI will hang after dialing EC, chances 3/5. Tracked by bug 963467.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.