If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Use build-time preference to enable rocketbar

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: kgrandon, Assigned: kgrandon)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
This is essentially a combination of four bugs in the Rocketbar branch, which we need to handle with a build-time preference instead.

The bugs are: 941276, 960344, 960249, 960884
(Assignee)

Comment 1

4 years ago
Created attachment 8363853 [details] [review]
Github pull request
(Assignee)

Comment 2

4 years ago
Comment on attachment 8363853 [details] [review]
Github pull request

Yuren, Vivien - this patch adds code to allow us to disable/enable rocketbar at build time. The code in this patch currently enables the preference as the assumption is that we will ship this in 1.4. 

This is mainly being used as a safety, and the specialized code in build/ can be removed as we near feature complete/branching.

If you have a bit of time I'd appreciate a review. Thanks!
Attachment #8363853 - Flags: review?(yurenju.mozilla)
Attachment #8363853 - Flags: review?(21)
Comment on attachment 8363853 [details] [review]
Github pull request

Made some comment on github. The approach sounds good to me globally.
Attachment #8363853 - Flags: review?(21)
(Assignee)

Comment 4

4 years ago
Comment on attachment 8363853 [details] [review]
Github pull request

Hi Vivien, addressed most of your comments. Let me know what you think.
Attachment #8363853 - Flags: review?(21)
See Also: → bug 956640
Comment on attachment 8363853 [details] [review]
Github pull request

looks good to me if we have some comment to explain that manifest.activities.view properties in webapp-manifest.js.

we also need to have some tests for applications-data.js/webapp-manifest.js but I would like to add it on bug 956640.
Attachment #8363853 - Flags: review?(yurenju.mozilla) → review+
(Assignee)

Comment 6

4 years ago
Comment on attachment 8363853 [details] [review]
Github pull request

Thanks for the review. Vivien - if you have any follow-up comments, let me know and we can address them. Going to land this after a few more Rocketbar patches land today for a more polished experience.
Attachment #8363853 - Flags: review?(21)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 941276
(Assignee)

Updated

4 years ago
Duplicate of this bug: 960344
(Assignee)

Updated

4 years ago
Duplicate of this bug: 960249
(Assignee)

Updated

4 years ago
Duplicate of this bug: 960884
Blocks: 941276

Updated

4 years ago
Blocks: 962004
(Assignee)

Comment 11

4 years ago
Now enabled by default, weee.

https://github.com/mozilla-b2g/gaia/commit/6b4def088138ef7d0af42767054d353be9d3bee3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.