Hide Window.openDialog from content

RESOLVED DUPLICATE of bug 789261

Status

()

defect
RESOLVED DUPLICATE of bug 789261
5 years ago
2 months ago

People

(Reporter: sicking, Unassigned)

Tracking

(Blocks 1 bug, {dev-doc-needed, site-compat})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

I think Window.openDialog is a gecko-specific thing. If so we should attempt to hide it from web content. I don't think it was ever intended to be used by the web but I can't see anything obvious that prevents it from being callable from the web. And the fact that window.openDialog tests true might affect future web standards as well as pollutes the global scope of the page.
Hmmm.. Window.webidl says that openDialog is [ChromeOnly]. However |typeof window.openDialog| returns "function" even in content pages?
Yeah, that's the XPIDL one you're seeing.
Ms2ger is right.  Once we finish moving Window to webidl, this will be fixed.

If we really wanted to we could try to do something with removing this from the xpidl, but then we have to make xrays work somehow....
Blocks: 789261
No longer blocks: 789261
Depends on: 789261
OS: Mac OS X → All
Hardware: x86 → All
Fixed by moving Window to WebIDL.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 789261
(Assignee)

Updated

2 months ago
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.