Closed Bug 962889 Opened 6 years ago Closed 6 years ago

[JA] add Bing to the default list of search providers in Firefox

Categories

(Mozilla Localizations :: ja / Japanese, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jnagel, Assigned: flod)

Details

Attachments

(1 file)

Hi, we would like to add Bing to the default list of search providers for the JA and JA-JP-Mac locale for the next release?  Bing seems to be missing from the list.  Bing should be listed in the search engine list in the 3rd position after Google and Yahoo! as part of our global agreement. 

Thank you!  Joanne
In my understanding, adding Bing is an option for localizers. And this is intended; the Japanese team has decided *not* to add Bing due to the small number of users.

https://blog.mozilla.org/blog/2010/10/06/refreshing-the-firefox-search-bar/
Hi Kohei,

Mozilla enters into agreements with many search partners and looks for more and more opportunities to provide variety of choices to the user. Our agreement with Microsoft concerning Bing is more recent than the blog post that you reference. Bing has grown to be a good alternative to other providers, better than it was four years ago. In fact, partner data has shown that there is a significant user base for Bing in Japan. Since there are already users there, it seems logical to provide these users with direct access to the provider. What are your thoughts?

Thanks
I have no objection here. Just wanted to explain why Bing has not came with the Japanese locale. Currently I have no right to decide.
(In reply to Kohei Yoshino [:kohei] from comment #3)
> I have no objection here. Just wanted to explain why Bing has not came with
> the Japanese locale. Currently I have no right to decide.

Thank you for the explanation. Since you've been the active Japanese localizer on this bug, would you introduce the topic to the l10n team please? It would be great to be able to move on this quickly. Thank you!
Assigning to ABE. ABE, what are your thoughts here?
Assignee: nobody → h.rayflood
Hi, just looking for an update.  Japan is an important locale for our Bing relationship and we would like to include them in the next release, if possible.  If there are concerns about their search results, I would be happy to share the details with them.  Could I please get an update?  Thanks! Joanne
This addition must be decided by Mozilla Japan marketing team.
I've already tell it to dynamis and they will answer.
Do we have an update to including Bing?  We have been looking at this for four months and it would be great to finalize the discussion.  Bing has been an important partner for Mozilla and we would like to include them unless there is a serious concern about their results.  Thanks, Joanne
Asai-san, could you please respond at least whether you are seeing this?
Flags: needinfo?(bugzilla)
Sorry I could not reply to this bug long time.
As far as I remember/heard, Bing was not included in the past because the number of the plug-ins are already large and initial search quality was not enough good.

Anyway, I'm now checking about the limit number of plugins and contracts with existing partners. Once all things become clear, we can add Bing to Japanese Firefox/Fennec.
Sorry but please wait a little more.
Flags: needinfo?(bugzilla)
Based on the discussion via email, this patch adds Bing as 3rd search engine on desktop, and simply adds Bing on mobile. No searchplugins are removed on Desktop for now.

I put items in alphabetical order in list.txt to make them easier to spot. This patch is for mozilla-beta/ja, but applies cleanly to mozilla-beta/ja-JP-mac as well.

@Dynamis
Can you take a look and let me know if it's OK for you?
Attachment #8445243 - Flags: feedback?(bugzilla)
Assignee: h.rayflood → francesco.lodolo
Comment on attachment 8445243 [details] [diff] [review]
bug962889v1.patch

Going for review.
Attachment #8445243 - Flags: feedback?(bugzilla) → review?(l10n)
Attachment #8445243 - Flags: review?(l10n) → review+
Thanks, landed on both ja and ja-JP-mac

http://hg.mozilla.org/releases/l10n/mozilla-beta/ja/rev/3da0fa5d2cd7
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/rev/3da0fa5d2cd7
http://hg.mozilla.org/l10n-central/ja/rev/09204465c3a5

http://hg.mozilla.org/releases/l10n/mozilla-beta/ja-JP-mac/rev/aea018b25b9d
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja-JP-mac/rev/aea018b25b9d
http://hg.mozilla.org/l10n-central/ja-JP-mac/rev/9105736c03b7

I couldn't merge aurora into central (I transplanted the changeset), and it's not clear if someone is actually working there (I'd say no). 

It would nice to put aurora and central in a mergeable state, feel free to file a bug and assign it to me if you want help.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Francesco Lodolo [:flod] from comment #11)
> @Dynamis
> Can you take a look and let me know if it's OK for you?

As we talked in mail, OK to add Bing for ja/ja-JP-mac.

(In reply to Francesco Lodolo [:flod] from comment #13)
> I couldn't merge aurora into central (I transplanted the changeset), and
> it's not clear if someone is actually working there (I'd say no). 
> 
> It would nice to put aurora and central in a mergeable state, feel free to
> file a bug and assign it to me if you want help.

I think ja/ja-JP-mac locales are maintained only for aurora/beta/releases usually.
Masahiko (or Abe or other locale owners), can you update central and merge this?
(In reply to dynamis (Tomoya ASAI) from comment #14)
> (In reply to Francesco Lodolo [:flod] from comment #11)
> > @Dynamis
> > Can you take a look and let me know if it's OK for you?
> 
> As we talked in mail, OK to add Bing for ja/ja-JP-mac.

Ahh, sorry I heard that we haven't confirmed contract condition aboout 1 plugin yet.
I believe we can change order of it but should not actually change files before confirmation.

Joanne Nagel and Tetsuya Kosaka are working to confirm it.

Please commit to releases branch after that.
# In theory, we should back-out the commit and re-commit it again after confirmation
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
> (In reply to Francesco Lodolo [:flod] from comment #11)
> > I couldn't merge aurora into central (I transplanted the changeset), and
> > it's not clear if someone is actually working there (I'd say no). 
> > 
> > It would nice to put aurora and central in a mergeable state, feel free to
> > file a bug and assign it to me if you want help.
> 
> I think ja/ja-JP-mac locales are maintained only for aurora/beta/releases
> usually.
> Masahiko (or Abe or other locale owners), can you update central and merge
> this?

Ignore about this.
Francesco have already committed into central. Masahiko need not update to central.
Nightly and Aurora already have difference changeset history and cannot fix to make them merge-able I think. If it's possible, better to make merge-able but need not.

(In reply to dynamis (Tomoya ASAI) from comment #15)
> Please commit to releases branch after that.
> # In theory, we should back-out the commit and re-commit it again after
> confirmation

To make it sure:

I believe we can confirm the contract soon. So keep change already committed unless existing contract deny to change the order. Please commit to releases after confirmation.
About the merge aurora-central. If l10n-central is completely unused, I could:
* Merge aurora into central, keeping the content currently on aurora in both repositories.
* Push the merged result into both repositories.

This way, whenever you want to sync aurora and central, you just need to pull new changesets into l10n-central from mozilla-aurora, no more merges needed. I just need to know if you're OK with me doing it.

To push these changes into release, you need to request a new sign-off for mozilla-beta in the l10n Dashboard. You need also a new sign-off on mozilla-aurora, to port these changes in beta. 

Last day to sign-off for Beta is Monday, July 14.
Please note, the only contract requirements are Google in #1 position, Yahoo in #2 position. I have confirmed there are no other provider requirements for search plugin position.
Since Joanne has clarified the contract requirements, let's proceed to sign offs so that this can be added to Release in time.
Now we need not back out to avoid affecting Release builds before the confirmation.
Sign-off for Beta have already done with Bing and it will be included for Firefox 31 Release.

Thanks Joanne and all.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.