Closed Bug 962906 Opened 7 years ago Closed 7 years ago

FxA age verification fails until system uptime is greater than 15 minutes

Categories

(Firefox for Android :: Android Sync, defect)

Firefox 29
All
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox29 --- verified
fennec 29+ ---

People

(Reporter: aaronmt, Assigned: rnewman)

Details

(Keywords: reproducible, Whiteboard: [qa+])

Currently, a user will be locked out (COPPA) by default on attempt to add a Firefox Account.

Steps to Reproduce

(Remove Nightly and all Firefox Accounts from your Android device)

i) Install Nightly
ii) Settings → Accounts → Firefox Account

* Boom*

Expected: First time setup
Actual: COPPA lockout

Also reproducible when starting the browser and then attempting to add an account

I/ActivityManager(  764): Displayed com.android.settings/.Settings: +509ms
I/ActivityManager(  764): START u0 {act=android.settings.ADD_ACCOUNT_SETTINGS cmp=com.android.settings/.accounts.AddAccountSettings} from pid 6385
I/ActivityManager(  764): START u0 {cmp=com.android.settings/.accounts.ChooseAccountActivity} from pid 6385
I/ActivityManager(  764): Displayed com.android.settings/.accounts.ChooseAccountActivity: +361ms (total +394ms)
I/ActivityManager(  764): Start proc org.mozilla.fennec for service org.mozilla.fennec/org.mozilla.gecko.fxa.authenticator.FxAccountAuthenticatorService: pid=6434 uid=10081 gids={50081, 3003, 1028, 1015}

I/ActivityManager(  764): START u0 {cmp=org.mozilla.fennec/org.mozilla.gecko.fxa.activities.FxAccountGetStartedActivity (has extras)} from pid 6385

I/FxAccounts( 6434): fennec :: FxAccountAgeLockoutHelper :: $$FxA PII$$: Checking if locked out: it's been 224267ms since last lockout, so yes.

I/ActivityManager(  764): START u0 {flg=0x10000 cmp=org.mozilla.fennec/org.mozilla.gecko.fxa.activities.FxAccountCreateAccountNotAllowedActivity} from pid 6434

I/ActivityManager(  764): Displayed org.mozilla.fennec/org.mozilla.gecko.fxa.activities.FxAccountCreateAccountNotAllowedActivity: +126ms (total +180ms)


--
Nightly (01/22)
Samsung Galaxy SII (Android 4.3), LG Nexus 4 (Android 4.4.2)
My LG Nexus 5 and Galaxy SII have not previously added any accounts. No idea where it's getting '224267ms' from - uptime? I just powered on the device.
Hah! This is what happens if you try to set up FxA within fifteen minutes of booting your phone. Lolbug. Will fix.

Great catch!
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Hardware: ARM → All
Summary: Firefox Accounts (Setup) - COPPA locked out by default; new profile → FxA age verification fails until system uptime is greater than 15 minutes
Flags: needinfo?(aaron.train)
Keywords: verifyme
Interesting, I thought uptime was lifetime uptime of the phone.  Which of course is not what *nix uptime is.  My brain is like mashed yams.  lolbug indeed.
tracking-fennec: ? → 29+
https://hg.mozilla.org/mozilla-central/rev/4b545aafeefc
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in services][qa+] → [qa+]
Target Milestone: --- → Firefox 29
Status: RESOLVED → VERIFIED
Flags: needinfo?(aaron.train)
Keywords: verifyme
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.