Closed Bug 962978 Opened 6 years ago Closed 6 years ago

TextureHost leaking mBuffer with OMTC on Linux

Categories

(Core :: Graphics: Layers, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: romaxa, Assigned: romaxa)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

It seems like latest trunk leaking mBuffer data in TextureClient/TextureHost

Regression seems coming from:
http://hg.mozilla.org/mozilla-central/rev/a283c87bafd1

MemoryTextureClient::Allocate - does alloc mBuffer
MemoryTextureClient::~MemoryTextureClient - does not delete buffer because IsSharedWithCompositor == true

TextureParent::ActorDestroy in case Deletion:
does not call DeallocateSharedData because TEXTURE_DEALLOCATE_CLIENT =false and TEXTURE_DEALLOCATE_DEFERRED = true.

so we jump onto mTextureHost->ForgetSharedData - which just forget mBuffer. - leak

after all that we coming into MemoryTextureHost::DeallocateSharedData
where mBuffer already null so no deletion happens
Attachment #8364206 - Flags: feedback?(bjacob)
Attachment #8364206 - Attachment is obsolete: true
Attachment #8364206 - Flags: feedback?(bjacob)
Attachment #8364212 - Flags: review?(nical.bugzilla)
Comment on attachment 8364212 [details] [diff] [review]
Don't drop mBuffer for deffered deallocate too early

Review of attachment 8364212 [details] [diff] [review]:
-----------------------------------------------------------------

Oh my, thanks!
Attachment #8364212 - Flags: review?(nical.bugzilla) → review+
https://hg.mozilla.org/mozilla-central/rev/a9a4736ea178
Assignee: nobody → romaxa
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.