In the Downloads window, put the menu bar, the essential global actions and their keyboard equivalents

RESOLVED DUPLICATE of bug 697359

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 697359
5 years ago
5 years ago

People

(Reporter: Nicolas Barbulesco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Firefox 26.

I have the (new) Downloads window. 

I did not even notice that there is no menu bar. On Windows, the habit is that all windows have their menu bar. 
I want to create a new window, so I press Ctrl N. 
 * I expect Firefox to create a new window. 
 * Firefox does nothing. 
Then I notice that the menu bar is missing.

My request is : 
 1) To have the menu bar here 
 2) To have the essential global actions of Firefox in the menu bar ("New window...", "About Firefox..."...) 
 3) To have the essential global key equivalents of Firefox work (Ctrl N...). 

I notice that Ctrl W works here.

Thank you.

Nicolas
Are you referring to the Library window?
Since, the new download manager is the panel (from the downloads button in the toolbar).
The Library will be moved to a tab (bug 697359) and then you will basically get what you are asking for. Since that bug is planned and is basically solving your report, I'm duping there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697359

Updated

5 years ago
Component: General → Downloads Panel
(Reporter)

Comment 2

5 years ago
(In reply to Marco Bonardo [:mak] from comment #1)

> Are you referring to the Library window?

Yes. What we have now with choosing Downloads in the menu Tools.

> The Library will be moved to a tab (bug 697359) and then you will basically
> get what you are asking for. Since that bug is planned and is basically
> solving your report, I'm duping there.

> *** This bug has been marked as a duplicate of bug 697359 ***

This bug (here) is not a duplicate. 
I think the in-content UI would be a bad idea. 
However, with in-content UI this bug would be resolved.
(In reply to Nicolas Barbulesco from comment #2)
> I think the in-content UI would be a bad idea. 

Unfortunately for your use-case, that's the plan, you may just file bugs to improve the in-content ui once it's there
You need to log in before you can comment on or make changes to this bug.