Firefox accounts (Android) - Can't confirm emails using Firefox mobile - the confirmation links are broken

VERIFIED FIXED

Status

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: csuciu, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 affected)

Details

(Whiteboard: [qa+])

No description provided.
Nightly 29.0a1 2013-01-23

Steps:
1. Create a new account using a yahoo/gmail email address
2. Open Yahoo/Gmail mail in Firefox mobile, open the confirmation email and tap on the confirmation link

Expected:
The link loaded in the url bar should be identical with the one from the email

Actual:
The link in the url bar is slightly different, therefore a 'Bad request' message is displayed instead of verifying the account successfully.

For ex: 
Link from email:
https://api-accounts-onepw.dev.lcip.org/v1/verify_email?uid=25e593dc70fb43af81e4a505a3626e87&code=fcef7ff48e230e163358a71cbeae74a3  
Link loaded in url bar:
https://api-accounts-onepw.dev.lcip.org/v1/verify_email?uid=25e593dc70fb43af81e4a505a3626e87&code=fcef7ff48e230e163358a71cbeae74a3
Summary: Can't open confirmation links in Fennec → Firefox accounts (Android) - Can't confirm emails using Firefox mobile - the confirmation links are broken
tracking-fennec: --- → ?
This is an fxa-auth-server and fxa-content-server thing, I think.  nchapman, or dcoates, can you direct this ticket to the person who can make sure this works on Firefox for Android?  Thanks.
Flags: needinfo?(nchapman)
Flags: needinfo?(dcoates)
Whiteboard: [qa+]
tracking-fennec: ? → 29+
Component: Android Sync → Server: Firefox Accounts
Product: Android Background Services → Mozilla Services
QA Contact: jbonacci
Hardware: ARM → All
Version: Firefox 29 → unspecified
https://api-accounts-onepw.dev.lcip.org was running an outdated build. This bug was fixed in: https://github.com/mozilla/fxa-auth-server/commit/7f0d608d4c23114676e699b4f310f51541e36500

I've updated the server to master, commit 570304aaabf8f5fb183a00dacb3f9bcada4b2d68
Flags: needinfo?(nchapman)
Flags: needinfo?(dcoates)
tracking-fennec: 29+ → ---
Blocks: 799726
No longer blocks: 905997
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Can't reproduce using the latest nightly
Closing
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.